как мне решить проблему зависимости? в ubuntu 18.04 lts

строгий текст , когда я пытаюсь установить какой-либо программный пакет, в конце мне показывают несколько ошибок зависимостей, как показано ниже:

 dpkg: error processing package systemd (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     python3
     apparmor
     snapd
     passwd
     adduser
     openssh-client
     dirmngr
     gnupg
     gpg-wks-client
     udev
     systemd
    E: Sub-process /usr/bin/dpkg returned an error code (1)

Я попытался исправить это, и теперь я застрял здесь: * * я получаю эту ошибку: (это вывод)

 najeeb@najeeb-Vostro-3480:~$ sudo apt-get install stacer
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    stacer is already the newest version (1.1.0-1bionic).
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     aspell : Depends: dictionaries-common (> 0.40) but it is not going to be installed
     aspell-en : Depends: dictionaries-common (>= 0.49.2) but it is not going to be installed
     dictionaries-common-dev : Depends: dictionaries-common (>= 1.22.3) but it is not going to be installed
     hunspell-en-us : Depends: dictionaries-common (>= 0.10) but it is not going to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).**

и вывод: " $ apt-cache policy stacer aspell python3 systemd" :

  najeeb@najeeb-Vostro-3480:~$ apt-cache policy stacer aspell python3 systemd
stacer:
  Installed: 1.1.0-1bionic
  Candidate: 1.1.0-1bionic
  Version table:
 *** 1.1.0-1bionic 500
        500 http://ppa.launchpad.net/oguzhaninan/stacer/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
aspell:
  Installed: 0.60.7~20110707-4ubuntu0.1
  Candidate: 0.60.7~20110707-4ubuntu0.1
  Version table:
 *** 0.60.7~20110707-4ubuntu0.1 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        500 http://in.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     0.60.7~20110707-4 500
        500 http://in.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
python3:
  Installed: 3.6.7-1~18.04
  Candidate: 3.6.7-1~18.04
  Version table:
 *** 3.6.7-1~18.04 500
        500 http://in.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.6.5-3 500
        500 http://in.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
systemd:
  Installed: 237-3ubuntu10.45
  Candidate: 237-3ubuntu10.45
  Version table:
 *** 237-3ubuntu10.45 500
        500 http://in.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     237-3ubuntu10.38 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     237-3ubuntu10 500
        500 http://in.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

и когда я попробуйте команду "apt --fix-broken install", я все равно получаю ту же ошибку. пожалуйста, помогите мне!

0
задан 6 April 2021 в 10:58

1 ответ

Похоже, у вас не работает установка Ubuntu.

Я знаю, что это может быть не самое элегантное решение, но лучший способ решить эту проблему - просто переустановить Ubuntu.

0
ответ дан 23 April 2021 в 23:25

Другие вопросы по тегам:

Похожие вопросы: