Предупреждения во время установки pip из-за пакета с именем «-etuptools»

Простая проблема. Когда я устанавливаю или обновляю пакеты с помощью pip, я получаю очень странную ошибку. Вход:

pip3 install numpy

выход:

Defaulting to user installation because normal site-packages is not writeable
WARNING: Ignoring invalid distribution -etuptools (/home/max/.local/lib/python3.8/site-packages)
WARNING: Ignoring invalid distribution -etuptools (/home/max/.local/lib/python3.8/site-packages)
Requirement already satisfied: numpy in /home/max/.local/lib/python3.8/site-packages (1.20.2)
WARNING: Ignoring invalid distribution -etuptools (/home/max/.local/lib/python3.8/site-packages)
WARNING: Ignoring invalid distribution -etuptools (/home/max/.local/lib/python3.8/site-packages)
WARNING: Ignoring invalid distribution -etuptools (/home/max/.local/lib/python3.8/site-packages)

Есть идеи, что случилось?

ОС: Ubuntu 20.04

Python: 3.8.5

setupools: 56.0.0

0
задан 4 May 2021 в 19:18

1 ответ

Похоже, что numpy уже успешно установлен. вы пробовали получить доступ к нему с помощью чего-то вроде:

python3
>>> import numpy
>>> a=numpy.zeros(10,numpy.uint8,"C")
>>> a
array([0, 0, 0, 0, 0, 0, 0, 0, 0, 0], dtype=uint8)
>>> 
0
ответ дан 7 May 2021 в 17:40

Другие вопросы по тегам:

Похожие вопросы: