Помогите избавиться от неудовлетворенных зависимостей [дубликат]

когда я пытаюсь установить он показывает это. Помогите мне избавиться от этого. Я пытался установить codeblocks один раз с помощью команды dpkg. Я использую ubuntu 20.04

reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 codeblocks-contrib : Depends: libboost-system1.62.0 but it is not installable
                      Depends: libhunspell-1.4-0 but it is not installable
                      Depends: libwxgtk3.0-0v5 (>= 3.0.2+dfsg) but it is not installable
                      Depends: libwxsmithlib0 (= 20.03) but 20.03-3 is to be installed
                      Depends: codeblocks (= 20.03) but it is not going to be installed
                      Recommends: valgrind but it is not going to be installed
                      Recommends: cppcheck but it is not going to be installed
                      Recommends: cscope but it is not going to be installed
                      Recommends: cccc but it is not going to be installed
 codeblocks-dev : Depends: libcodeblocks0 (= 20.03) but 20.03-3 is to be installed
 codeblocks-libwxcontrib0 : Depends: libwxgtk3.0-0v5 (>= 3.0.2+dfsg) but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

0
задан 28 June 2021 в 16:45

2 ответа

Шаг 1:

Для начала я бы предложил попробовать всю процедуру установки с помощью aptitude, поскольку он предоставляет решения, которые в большинстве случаев работают.

sudo apt update
sudo apt install aptitude    

А затем попробуйте загрузить ваш пакет с помощью aptitude:

sudo aptitude install <package-name>

Шаг 2:

Если это не сработает, попробуйте загрузить зависимости по одной, чтобы увидеть, исчезнет ли проблема.

sudo apt install -f libcodeblocks0=20.03 # -f flag means fix broken
sudo apt install -f libwxgtk3.0-0v5=3.0.2+dfsg
sudo apt install -f libboost-system1.62.0
sudo apt install -f libhunspell-1.4-0
sudo apt install -f libwxsmithlib0=20.03

Шаг 3:

Если вышеуказанные шаги не помогли (что, я полагаю, может произойти, так как некоторые пакеты помечены как не устанавливаемые), попробуйте загрузить эти пакеты из реестра Ubuntu для архитектуры вашего компьютера (я перечислю для amd64)

Ссылки:

libwxgtk3. 0-0v5

codeblocks

libcodeblocks0

libhunspell-1.4-0 (справа, под загружаемыми файлами)

libwxsmithlib0

libboost-system1.62.0

Надеюсь, это решит проблему. Если нет, прокомментируйте ниже.

-1
ответ дан 28 July 2021 в 11:24

. Я предлагаю вам выполнить следующие команды, которые могут установить программное обеспечение и удалить сообщение об ошибке

sudo apt --fix-broken install

sudo apt update

sudo apt-get upgrade

sudo apt install codeblocks
1
ответ дан 28 July 2021 в 11:24

Другие вопросы по тегам:

Похожие вопросы: