Неудовлетворенные зависимости для zsnes (работает на одном компьютере, но не на моем другом) [дубликат]

Когда я пробую (в Ubuntu 18.04.5 LTS)

sudo apt install zsnes

, я получаю следующее

Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming. 
The following information may help to resolve the situation:
    
The following packages have unmet dependencies:
    zsnes:i386 : Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not going to be installed

Я затем пытаюсь

sudo apt install libsdl1.2debian:i386

получаю следующее

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    kio : Depends: libkf5notifications5 (>= 4.96.0) but it is not going to be installed
          Depends: libkf5wallet-bin but it is not going to be installed
    libkf5wallet5 : Depends: libkwalletbackend5-5 (= 5.44.0-0ubuntu1) but it is not going to be installed
    libsdl1.2debian:i386 : Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not going to be installed

Я продолжаю идти в кроличью нору, пытаясь установить эти неудовлетворенные зависимости, и я просто не в себе. Может кто-то указать мне верное направление? У меня дома 2 linux машины (2 ноутбука). На одном ноутбуке нет проблем с установкой zsnes, но на другом моем ноутбуке просто постоянно возникают ошибки. Оба моих ноутбука работают под управлением Ubuntu 18.04.5 LTS, поэтому я не понимаю, почему на одном компьютере с одной и той же ОС нет проблем с установкой программы, а на другом - нет.

Я попробовал решение здесь, но оно не сработало Неудовлетворенные зависимости (linux-headers, linux-image)

Я пробовал

sudo apt --fix-broken install

, и это не устранило проблему. Я также уже запускал

sudo apt update

и

sudo apt upgrade

и даже

sudo dpkg --configure -a
sudo apt clean
sudo apt autoclean
sudo apt -f install

, и все та же проблема. Когда я запускаю

cat /etc/apt/sources.list

, я получаю это

deb http://us.archive.ubuntu.com/ubuntu/ bionic universe multiverse main
deb http://security.ubuntu.com/ubuntu bionic main
# deb-src http://security.ubuntu.com/ubuntu bionic main
0
задан 9 June 2021 в 23:16

1 ответ

Спасибо Ray Ву за то, что спросил меня, что есть в моем файле sources.list. Первоначально у него были только следующие источники.

deb http://us.archive.ubuntu.com/ubuntu/ bionic universe multiverse main
deb http://security.ubuntu.com/ubuntu bionic main
# deb-src http://security.ubuntu.com/ubuntu bionic main

Затем я проверил свой другой компьютер и сделал свой файл sources.list таким.

deb http://us.archive.ubuntu.com/ubuntu/ bionic universe multiverse main restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main universe restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic-backports main multiverse universe restricted
deb http://security.ubuntu.com/ubuntu bionic main
deb http://security.ubuntu.com/ubuntu bionic-security main restricted universe multiverse

Затем я запустил обновление и обновление, и теперь zsnes устанавливается без проблем. Спасибо!!!

0
ответ дан 28 July 2021 в 11:30

Другие вопросы по тегам:

Похожие вопросы: