.waf configure возвращает ошибку "Проверка заголовка boost / format.hpp: not found"

Я пытаюсь установить patchage 1.0. 4 с этого веб-сайта и './waf configure' возвращает эту ошибку. Также я новичок в Linux, поэтому я мало что понимаю. это изображение сообщения об ошибке

Заранее благодарим за помощь.

1
задан 12 August 2021 в 15:07

1 ответ

Для последней версии Ubuntu 21.04 вам нужно использовать следующие команды для получения всех зависимостей и компиляции приложения patchage:

sudo apt-get install python-is-python3 libdbus-1-dev libdbus-glib-1-dev libglibmm-2.4-dev libgtkmm-2.4-dev libganv-dev libjack-dev libasound2-dev libboost1.74-dev libfmt-dev

cd ~/Downloads
wget -c http://download.drobilla.net/patchage-1.0.4.tar.bz2
tar -xf patchage-1.0.4.tar.bz2
cd patchage-1.0.4
./waf configure
./waf
sudo ./waf install
2
ответ дан 20 August 2021 в 10:27

Другие вопросы по тегам:

Похожие вопросы: