Не могу установить GeoDa в Ubuntu 21.04

Я пытаюсь установить Geoda в свой Linux, но я ' m возникла проблема:

GeoDa: https://geodacenter.github.io/download_linux.html

$sudo dpkg -i geoda_1.18-1focal1_amd64.deb
(Reading database ... 599099 files and directories currently installed.)
Preparing to unpack geoda_1.18-1focal1_amd64.deb ...
Unpacking geoda (1.18-1focal1) over (1.18-1focal1) ...
dpkg: dependency problems prevent configuration of geoda:
 geoda depends on libgdal26; however:
  Package libgdal26 is not configured yet.

dpkg: error processing package geoda (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.26-1ubuntu1) ...
Processing triggers for mailcap (3.68ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 geoda

Я попытался установить ligdal26, но мне это не удалось.

libgdal26: https://packages.ubuntu.com/focal/amd64/libgdal26/download

$ sudo dpkg -i libgdal26_3.0.4+dfsg-1build3_amd64.deb
(Reading database ... 599099 files and directories currently installed.)
Preparing to unpack libgdal26_3.0.4+dfsg-1build3_amd64.deb ...
Unpacking libgdal26 (3.0.4+dfsg-1build3) over (3.0.4+dfsg-1build3) ...
dpkg: dependency problems prevent configuration of libgdal26:
 libgdal26 depends on libarmadillo9 (>= 1:9.800.4+dfsg); however:
  Package libarmadillo9 is not installed.
 libgdal26 depends on libcfitsio8 (>= 3.470~); however:
  Package libcfitsio8 is not installed.
 libgdal26 depends on libdap25 (>= 3.20.5); however:
  Package libdap25 is not installed.
 libgdal26 depends on libhdf5-103; however:
  Package libhdf5-103 is not installed.
 libgdal26 depends on libjson-c4 (>= 0.13.1); however:
  Package libjson-c4 is not installed.
 libgdal26 depends on libnetcdf15 (>= 1:4.0.0); however:
  Package libnetcdf15 is not installed.
 libgdal26 depends on libpoppler97 (>= 0.86.1); however:
  Package libpoppler97 is not installed.
 libgdal26 depends on libproj15 (>= 6.0.0); however:
  Package libproj15 is not installed.
 libgdal26 depends on libqhull7; however:
  Package libqhull7 is not installed.

dpkg: error processing package libgdal26 (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.33-0ubuntu5) ...
Errors were encountered while processing:
 libgdal26

Кто-нибудь знает решение? Или GeoDa доступна только для LTS-версии?

Версия для Linux:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 21.04
Release:    21.04
Codename:   hirsute
2
задан 2 September 2021 в 00:50

4 ответа

Вы по-прежнему можете установить GeoDa, используя приведенные ниже команды, чтобы получить все зависимости от Ubuntu 21.04:

cd ~/Downloads

wget -c https://github.com/GeoDaCenter/geoda/releases/download/v1.18/geoda_1.18-1focal1_amd64.deb

wget -c http://archive.ubuntu.com/ubuntu/pool/universe/a/armadillo/libarmadillo9_9.800.4+dfsg-1build1_amd64.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/c/cfitsio/libcfitsio8_3.470-3_amd64.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/libd/libdap/libdap25_3.20.5-1_amd64.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gdal/libgdal26_3.0.4+dfsg-1build3_amd64.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/h/hdf5/libhdf5-103_1.10.4+repack-11ubuntu1_amd64.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/j/json-c/libjson-c4_0.13.1+dfsg-7ubuntu0.3_amd64.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/n/netcdf/libnetcdf15_4.7.3-1_amd64.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/main/p/poppler/libpoppler97_0.86.1-0ubuntu1_amd64.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/p/proj/libproj15_6.3.1-1_amd64.deb
wget -c http://archive.ubuntu.com/ubuntu/pool/universe/q/qhull/libqhull7_2015.2-4_amd64.deb

sudo apt update
sudo apt install ./geoda_1.18-1focal1_amd64.deb ./libgdal26_3.0.4+dfsg-1build3_amd64.deb ./libarmadillo9_9.800.4+dfsg-1build1_amd64.deb ./libcfitsio8_3.470-3_amd64.deb ./libdap25_3.20.5-1_amd64.deb ./libhdf5-103_1.10.4+repack-11ubuntu1_amd64.deb ./libjson-c4_0.13.1+dfsg-7ubuntu0.3_amd64.deb ./libnetcdf15_4.7.3-1_amd64.deb ./libpoppler97_0.86.1-0ubuntu1_amd64.deb ./libproj15_6.3.1-1_amd64.deb ./libqhull7_2015.2-4_amd64.deb

, а затем использовать GeoDa.


Чтобы иметь меньше проблем в течение длительного периода времени, вы должны выполнить новую установку 20.04 LTS (долгосрочная поддержка, 5 лет обновлений) и прожить 4 года без забот.

1
ответ дан 4 September 2021 в 09:23

Попробуйте установить geoda_1.18-1focal1_amd64.deb с помощью gdebi.

Утилита gdebi автоматически подтягивает необходимые зависимости.

Сначала установите gdebi:

sudo apt-add-repository universe
sudo apt update
sudo apt install gdebi-core

Затем установите GeoDa, используя:

sudo gdebi geoda_1.18-1focal1_amd64.deb
0
ответ дан 4 September 2021 в 09:23

Обновление : Я попробовал метод от N0rbert и он работает для меня на Ubuntu 21.04.

В Ubuntu 21.04 я установил GeoDa в машину VirtualBox из Ubuntu 20.04.3 ISO.

Другим решением может быть создание USB-носителя (живого или постоянного) с Ubuntu 20.04.3 ISO. Я тестировал его с живым USB (вы можете установить программное обеспечение, но конфигурация сбрасывается при перезагрузке). Я считаю, что это отлично подходит для тестов, если я напишу шаги.

Следующие команды позволяют мне установить GeoDa :

sudo add-apt-repository universe
sudo apt update
sudo apt-get install freeglut3 libpq5 libgdal26

Затем я нажал на geoda_1.18-1focal1_amd64.deb для установки и поиска GeoDa в Applications.

enter image description here

Примечание : Я являюсь пользователем других дистрибутивов Linux. Я также установил GeoDa с Linux Mint 20.02 (он основан на Ubuntu 20.04 LTS). Я не помню, одинаковы ли шаги. Это был просто тест.

Мне не повезло с gdebi для установки непосредственно на Ubuntu 21.04.

sudo gdebi geoda_1.18-1focal1_amd64.deb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: libgdal26
2
ответ дан 4 September 2021 в 09:23

Добро пожаловать в Linux-версию Dependency Hell. Проверьте сайт geoda, чтобы узнать предварительные требования. Установите их.

Вы можете попробовать установить зависимости (и их зависимости) и ..., это либо сработает, либо не сработает, если требуемая версия 17 foolib недоступна для вашей системы.

0
ответ дан 4 September 2021 в 09:23

Другие вопросы по тегам:

Похожие вопросы: