Невозможно обновить Ubuntu 16.04 до 20.04 [дубликат]

Мне нужно обновить ubuntu 16.04 до 20.04. Когда я использую графический интерфейс, всплывающие окна сообщают мне, что все обновлено, а Ubuntu сообщает мне, что сначала необходимо установить 18.04, что это нормально.

Но когда я нажимаю, ничего не происходит.

Когда я использую командную строку: sudo do-release-upgrade У меня появляется сообщение:

Пожалуйста, перед обновлением установите все доступные обновления для вашего выпуска.

Я не понимаю. У кого-нибудь есть идея?

Извините за мой плохой английский

0
задан 29 August 2021 в 16:45

3 ответа

Вам необходимо убедиться, что ваша система xenial или 16.04 полностью обновлена, прежде чем вы сможете выпуск-обновление .

Сообщение об ошибке сообщает вам, что вы не применили все обновления 16.04.

Я бы предложил

sudo apt update

и прочитайте сообщения, убедитесь, что нет ошибок ( или отсутствуют строки ), затем

sudo apt full-upgrade

и при условии применения всех обновлений ( и исходные коды не отсутствуют в apt update , которое вы запускали ранее ), вам может потребоваться перезагрузка, затем do-release-upgrade должно работать.

0
ответ дан 4 September 2021 в 09:27

Большое спасибо.

Да, на самом деле у меня были ошибки во время sudo apt update . Так что снимаю некоторые отложения (скайп и другие). Сейчас все в порядке. Я могу обновить 16.04 до 18.04.

1
ответ дан 4 September 2021 в 09:27

используйте sudo apt update && sudo apt upgrade && sudo apt full-upgrade , а затем обновите до 18.04, а затем до 20.04

0
ответ дан 4 September 2021 в 09:27

Другие вопросы по тегам:

Похожие вопросы: