Неудовлетворенные зависимости с Python3-dev - Apt кажется сломанным

В Ubuntu 20.04, и для попытки установить ROS2 Galactic требуется следующий пакет: sudo apt install -y libpython3-dev Однако это возвращает следующее:

Некоторые пакеты не могут быть установлены. Это может означать, что у вас есть запросил невозможную ситуацию или если вы используете нестабильный дистрибутив, в котором еще не созданы некоторые требуемые пакеты или был перемещен из списка входящих. Следующая информация может помочь разрешить ситуацию: Следующие пакеты имеют неудовлетворенные зависимости: libpython3-dev: Зависит от: libpython3.8-dev (> = 3.8.2-1 ~), но он не будет установлен E: Не удалось исправить проблемы, у вас есть неработающие пакеты

Я попытался установить libpython3.8-dev , который возвращает неудовлетворенную зависимость

Следующие пакеты имеют неудовлетворенные зависимости: libpython3.8-dev: Зависит от libexpat1-dev, но он не будет установлен Рекомендует: libc6-dev, но не будет устанавливаться или libc-dev

Эта цепочка продолжается некоторое время.

В конечном итоге приводит к:

libc6-dev: Зависит от: libc6 (= 2.31-0ubuntu9), но необходимо установить 2.31-0ubuntu9.2 потом libc6 - это уже самая новая версия (2.31-0ubuntu9.2).

Я пробовал:

  • sudo apt autoremove
  • Главное, вселенная и мультивселенная выбраны как PPA
  • sudo dpkg --configure -a
  • sudo apt-get -f install
  • sudo apt-get autoclean
  • sudo apt-get -u dist-upgrade

Мне кажется, что apt не работает, это относительно новая установка Ubuntu 20.04, поэтому не знаю почему. У меня были похожие проблемы со сломанным APT, и в итоге я просто переустановил Ubuntu, чтобы сэкономить время. Но на этот раз я хочу разобраться в проблеме. Любая помощь приветствуется.

- Вывод sudo apt update

Hit: 1 https://brave-browser-apt-release.s3.brave.com стабильный InRelease Обращение: 2 http://ca.archive.ubuntu.com/ubuntu focal InRelease
Обращение: 3 http://security.ubuntu.com/ubuntu focal-security InRelease
Обращение: 4 http://archive.canonical.com/ubuntu focal InRelease
Хит: 5 http://packages.ros.org/ros2/ubuntu focal InRelease Чтение списков пакетов ... Готово Построение дерева зависимостей
Чтение информации о состоянии ... Готово Все пакеты обновлены.

0
задан 30 October 2021 в 21:12

0 ответов

Другие вопросы по тегам:

Похожие вопросы: