Система пакетов не работает. Не удалось это исправить

Я испробовал множество способов в Интернете, чтобы исправить Например, запуск sudo apt-get -f install и sudo apt-get clean

вот что я получаю, когда пытаюсь выполнить обновление с помощью средства обновления программного обеспечения:

Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f
Transaction failed: The package system is broken
 The following packages have unmet dependencies:

libpam-modules: PreDepends: libaudit1 (>= 1:2.2.1) but 1:2.8.5-2ubuntu6 is installed
                PreDepends: libc6 (>= 2.27) but 2.31-0ubuntu9.2 is installed
                PreDepends: libcrypt1 (>= 1:4.1.0) but 1:4.4.10-10ubuntu4 is installed
                PreDepends: libselinux1 (>= 2.1.9) but 3.0-1build2 is installed
                PreDepends: libpam-modules-bin (= 1.3.1-5ubuntu4.2) but 1.3.1-5ubuntu4.3 is installed

я пытался следовать этому руководству отвечать. но это не помогло: Как разрешить неудовлетворенные зависимости после добавления PPA?

результат sudo apt-get update :

E: The repository 'http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Я использую версию 20.04, кстати. Я нуб, поэтому я не уверен, что делаю, мне просто нужно исправить это

редактирование: результат sudo get update :

Hit:1 http://archive.canonical.com/ubuntu focal InRelease
Get:2 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Hit:3 http://de.archive.ubuntu.com/ubuntu focal InRelease                               
Hit:4 http://de.archive.ubuntu.com/ubuntu focal-updates InRelease
Get:5 http://de.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Get:6 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [29,0 kB]
Get:7 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [63,7 kB]
Get:8 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2.464 B]
Fetched 310 kB in 2s (148 kB/s)               
Reading package lists... Done
Building dependency tree       
Reading state information... Done
58 packages can be upgraded. Run 'apt list --upgradable' to see them.

результат sudo get upgrade :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libpam-modules : PreDepends: libpam-modules-bin (= 1.3.1-5ubuntu4.2)
                  Recommends: update-motd but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

результат apt --fix-broken install

apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libgsoap-2.8.91 libllvm11 liblzf1 libvncserver1 shim virtualbox-dkms
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libpam-modules
Recommended packages:
  update-motd
The following packages will be upgraded:
  libpam-modules
1 upgraded, 0 newly installed, 0 to remove and 57 not upgraded.
Need to get 0 B/260 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Reading database ... 258871 files and directories currently installed.)
Preparing to unpack .../libpam-modules_1.3.1-5ubuntu4.3_amd64.deb ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing archive /var/cache/apt/archives/libpam-modules_1.3.1-5ubuntu4.3_amd64.deb (--unpack):
 new libpam-modules:amd64 package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libpam-modules_1.3.1-5ubuntu4.3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

результат sudo apt autoremove

sudo apt autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libpam-modules : PreDepends: libpam-modules-bin (= 1.3.1-5ubuntu4.2)
                  Recommends: update-motd but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

вывод apt policy libpam-modules

libpam-modules:
  Installed: 1.3.1-5ubuntu4.2
  Candidate: 1.3.1-5ubuntu4.3
  Version table:
     1.3.1-5ubuntu4.3 500
        500 http://de.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
 *** 1.3.1-5ubuntu4.2 100
        100 /var/lib/dpkg/status
     1.3.1-5ubuntu4 500
        500 http://de.archive.ubuntu.com/ubuntu focal/main amd64 Packages

Я не могу установить диспетчер пакетов Synaptic, так как не могу установить никакие программы

2
задан 19 October 2021 в 20:49

0 ответов

Другие вопросы по тегам:

Похожие вопросы: