OpenShot не будет обновляться

Я только что установил видеоредактор openshot через терминал: это руководство https://www.ubuntupit.com/install-openshot-video-editor-ubuntu-linux-mint/ на Ubuntu 21.04 на Raspberry Pi 4b. Я попытался запустить его, но он показал это предупреждение о сбое, и openshot не запустился.

enter image description here

Вот кое-что, что N0rbert хотел, чтобы я сделал в терминале (сначала я этого не понял), но вот оно. Внизу этого есть дополнительная запись терминала, которую Орберт хотел, чтобы я добавил, поэтому я тоже это сделал.

pi@pi-raspberrypi:~$ sudo su
[sudo] password for pi: 
root@pi-raspberrypi:/home/pi# apt-cache policy openshot
openshot:
  Installed: (none)
  Candidate: 2.5.1+dfsg1-1
  Version table:
     2.5.1+dfsg1-1 500
        500 http://ports.ubuntu.com/ubuntu-ports hirsute/universe arm64 Packages
root@pi-raspberrypi:/home/pi# snap list | grep -i openshot
root@pi-raspberrypi:/home/pi#  flatpak list | grep -i openshot
Command 'flatpak' not found, but can be installed with:
apt install flatpak
root@pi-raspberrypi:/home/pi# apt install flatpak
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libappstream-glib8 libmalcontent-0-0 libostree-1-1
Suggested packages:
  malcontent-gui
The following NEW packages will be installed:
  flatpak libappstream-glib8 libmalcontent-0-0 libostree-1-1
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,460 kB of archives.
After this operation, 5,902 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ports.ubuntu.com/ubuntu-ports hirsute/universe arm64 libappstream-glib8 arm64 0.7.18-1 [129 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports hirsute/universe arm64 libmalcontent-0-0 arm64 0.10.0-2 [19.8 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports hirsute/universe arm64 libostree-1-1 arm64 2020.8-2 [266 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports hirsute/universe arm64 flatpak arm64 1.10.2-1ubuntu1 [1,045 kB]
Fetched 1,460 kB in 1s (1,516 kB/s)
Selecting previously unselected package libappstream-glib8:arm64.
(Reading database ... 276399 files and directories currently installed.)
Preparing to unpack .../libappstream-glib8_0.7.18-1_arm64.deb ...
Unpacking libappstream-glib8:arm64 (0.7.18-1) ...
Selecting previously unselected package libmalcontent-0-0:arm64.
Preparing to unpack .../libmalcontent-0-0_0.10.0-2_arm64.deb ...
Unpacking libmalcontent-0-0:arm64 (0.10.0-2) ...
Selecting previously unselected package libostree-1-1:arm64.
Preparing to unpack .../libostree-1-1_2020.8-2_arm64.deb ...
Unpacking libostree-1-1:arm64 (2020.8-2) ...
Selecting previously unselected package flatpak.
Preparing to unpack .../flatpak_1.10.2-1ubuntu1_arm64.deb ...
Unpacking flatpak (1.10.2-1ubuntu1) ...
Setting up libappstream-glib8:arm64 (0.7.18-1) ...
Setting up libostree-1-1:arm64 (2020.8-2) ...
Setting up libmalcontent-0-0:arm64 (0.10.0-2) ...
Setting up flatpak (1.10.2-1ubuntu1) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for dbus (1.12.20-1ubuntu3) ...
Processing triggers for libc-bin (2.33-0ubuntu5) ...
root@pi-raspberrypi:/home/pi# snap list | grep -i openshot
root@pi-raspberrypi:/home/pi# which openshot
root@pi-raspberrypi:/home/pi# 

pi@pi-raspberrypi:~$ apt-cache  policy openshot-qt libopenshot
openshot-qt:
  Installed: 2.6.0+dfsg2+1454+202108251849~ubuntu21.04.1
  Candidate: 2.6.0+dfsg2+1454+202108251849~ubuntu21.04.1
  Version table:
 *** 2.6.0+dfsg2+1454+202108251849~ubuntu21.04.1 500
        500 http://ppa.launchpad.net/openshot.developers/ppa/ubuntu hirsute/main arm64 Packages
        100 /var/lib/dpkg/status
     2.5.1+dfsg1-1 500
        500 http://ports.ubuntu.com/ubuntu-ports hirsute/universe arm64 Packages
libopenshot:
  Installed: (none)
  Candidate: (none)
  Version table:
pi@pi-raspberrypi:~$

Я сделал эти записи одну за другой плюс еще пару за одну терминальную сессию. Они были предложены в комментарии к этому вопросу NOrbert, поэтому я сделал их здесь. Я попытался запустить apt-update и full-upgrade в терминале, но обновление не произошло. Как мне установить последний установщик? Как это исправить?

2
задан 19 October 2021 в 18:48

0 ответов

Другие вопросы по тегам:

Похожие вопросы: