Сетевые устройства могут использовать сервер bind9, но сам сервер не может

Я работал над настройкой сервера bind9 на моем домашнем сервере, на котором запущен Ubuntu Server 16.04, чтобы разрешить мне доступ к моим службам по имени, а не к IP-адресу.

Сам сервер привязки ( в основном) настроены и работают отлично. Я могу разрешать имена хостов из IP-адресов и IP-адресов из имен хостов на своих сетевых устройствах, но сам сервер не может разрешить что-либо из своих собственных записей bind9, и это оставляет меня немного озадаченным.

Единственные серверы имен в /etc/resolv.conf - мой маршрутизатор 192.168.1.1 и 8.8.8.8.

Они настроены в моем /etc/network/interfaces. Я предполагаю, что моя проблема в том, что 127.0.0.1 не существует, поэтому сам сервер сразу же ищет мой маршрутизатор для разрешения адресов, а затем 8.8.8.8, но когда я добавляю 127.0.0.1 в /etc/network/interfaces, тогда ничего другого добавляется в /etc/resolv.conf, поэтому я остался с единственным сервером имен 127.0.0.1

У меня есть форвардеры, настроенные в /etc/bind/named.conf.local, и они работают, потому что я все еще могу получить доступ к Интернету , но из каждого руководства, которое я прочитал, bind9 должен добавлять 127.0.0.1 в /etc/resolv.conf, что означает, что он по-прежнему также заполняется серверами в моем файле /etc/network/interfaces, так что мой сервер все еще «в сети», даже если сервер привязки по какой-то причине.

Я проверил /etc/default/bind9 и RESOLVCONF=yes есть

# run resolvconf? RESOLVCONF=yes # startup options for the server OPTIONS="-u bind"

Вот мой /etc/network/interfaces, если что-то не так там

/etc/network/interfaces # This file describes the network interfaces available on your system # and how to activate them. For more information, see interfaces(5). # The loopback network interface auto lo wlan0 iface lo inet loopback # The primary network interface #auto eth0 # iface eth0 inet static iface wlan0 inet static address 192.168.1.62 netmask 255.255.255.0 broadcast 192.168.1.255 network 192.168.1.0 wpa-ssid ############# wpa-psk **************** dns-nameservers 192.168.1.1 8.8.8.8 gateway 192.168.1.1 # mtu 1500

Вот мой /etc/bind/named.conf

acl mynetwork { 192.168.1.0/24; }; // This is the primary configuration file for the BIND DNS server named. // // Please read /usr/share/doc/bind9/README.Debian.gz for information on the // structure of BIND configuration files in Debian, *BEFORE* you customize // this configuration file. // // If you are just adding zones, please do that in /etc/bind/named.conf.local include "/etc/bind/named.conf.options"; include "/etc/bind/named.conf.local"; include "/etc/bind/named.conf.default-zones"; key rndc-key { algorithm hmac-md5; secret "*****************"; }; controls { inet 127.0.0.1 port 953 allow { 127.0.0.1; } keys { rndc-key; }; };

И мой /etc/bind/named.conf.options

options { directory "/var/cache/bind"; // If there is a firewall between you and nameservers you want // to talk to, you may need to fix the firewall to allow multiple // ports to talk. See http://www.kb.cert.org/vuls/id/800113 // If your ISP provided one or more IP addresses for stable // nameservers, you probably want to use them as forwarders. // Uncomment the following block, and insert the addresses replacing // the all-0's placeholder. forwarders { 192.168.1.1; 208.67.222.222; 208.67.220.220; 8.8.8.8; 8.8.4.4; }; //======================================================================== // If BIND logs error messages about the root key being expired, // you will need to update your keys. See https://www.isc.org/bind-keys //======================================================================== dnssec-validation auto; auth-nxdomain no; # conform to RFC1035 listen-on-v6 { any; }; forward first; };

Если вам нужно увидеть любой из файлов зон, спросите, пожалуйста, но я не думаю это проблема, поскольку разрешение имен отлично работает с другими устройствами, а не с самого сервера; если я не изменю свой файл /etc/network/interfaces и у меня 127.0.0.1 в качестве моего единственного DNS-сервера в /etc/resolv.conf, поэтому я предполагаю, что это был длинный мокрый способ задать мне вопрос. Как добавить 127.0.0.1 в список dns в /etc/resolv.conf вместо того, чтобы иметь его как единственную запись

0
задан Will 10 April 2017 в 23:11
поделиться

10 ответов

Я сам нашел решение (сорта).

Я отредактировал файл /etc/resolvconf/head и добавил строку nameserver 127.0.0.1 и вернул раздел [namespace] /etc/network/interfaces в нормальный режим. Теперь у меня есть 127.0.0.1 как первая запись в моем /etc/resolv.conf, за которой следуют серверы имен, перечисленные в моем /etc/network/interfaces

. Я до сих пор не знаю, почему bind не добавлял запись самостоятельно, но в по крайней мере, сейчас все работает.

0
ответ дан Will 22 May 2018 в 20:46
поделиться

Я сам нашел решение (сорта).

Я отредактировал файл /etc/resolvconf/head и добавил строку nameserver 127.0.0.1 и вернул раздел [namespace] /etc/network/interfaces в нормальный режим. Теперь у меня есть 127.0.0.1 как первая запись в моем /etc/resolv.conf, за которой следуют серверы имен, перечисленные в моем /etc/network/interfaces

. Я до сих пор не знаю, почему bind не добавлял запись самостоятельно, но в по крайней мере, сейчас все работает.

0
ответ дан Will 18 July 2018 в 12:13
поделиться

Я сам нашел решение (сорта).

Я отредактировал файл /etc/resolvconf/head и добавил строку nameserver 127.0.0.1 и вернул раздел [namespace] /etc/network/interfaces в нормальный режим. Теперь у меня есть 127.0.0.1 как первая запись в моем /etc/resolv.conf, за которой следуют серверы имен, перечисленные в моем /etc/network/interfaces

. Я до сих пор не знаю, почему bind не добавлял запись самостоятельно, но в по крайней мере, сейчас все работает.

0
ответ дан Will 24 July 2018 в 17:34
поделиться

Я сам нашел решение (сорта).

Я отредактировал файл /etc/resolvconf/head и добавил строку nameserver 127.0.0.1 и вернул раздел [namespace] /etc/network/interfaces в нормальный режим. Теперь у меня есть 127.0.0.1 как первая запись в моем /etc/resolv.conf, за которой следуют серверы имен, перечисленные в моем /etc/network/interfaces

. Я до сих пор не знаю, почему bind не добавлял запись самостоятельно, но в по крайней мере, сейчас все работает.

0
ответ дан Will 31 July 2018 в 20:37
поделиться
0
ответ дан Will 2 August 2018 в 15:33
поделиться
0
ответ дан Will 3 August 2018 в 17:52
поделиться
0
ответ дан Will 5 August 2018 в 02:31
поделиться
0
ответ дан Will 6 August 2018 в 19:38
поделиться
0
ответ дан Will 9 August 2018 в 00:04
поделиться
0
ответ дан Will 14 August 2018 в 18:22
поделиться

Другие вопросы по тегам:

Похожие вопросы: