10
ответов

17.04: использование matplotlib с основанием GTK?

В новой системе Ubuntu 17.04, с python и python-matplotlib, я захотел построить с использованием Matplotlib GTKAgg или GTKCairo. Это хорошо работает в 16.04, но нарушается в 17.04, в результате ...
вопрос задан: 22 August 2017 12:42
9
ответов

ВОЗМОЖНО понизить 17.04 до Gtk-2?

У меня есть критическое приложение на основе затмения, которое плохо работает с Gtk-3; поддержка продуктов говорит, что они получили много проблем, которые решаются путем понижения. Возможно ли понизить Zesty до Gtk-2? ...
вопрос задан: 12 May 2017 15:02
7
ответов

Настройка Ambiance GTK * просто * для одного пользователя

Можно ли настроить внешний вид темы Ambiance только для одного пользователя? Я читал о возможности сделать это: sudo vim /usr/share/themes/Ambiance/gtk-2.0/gtkrc, но может ...
вопрос задан: 25 November 2012 17:47
7
ответов

Компиляция программного обеспечения с GTK, у которого нет сценария конфигурации

Я столкнулся с зеленым, просмотрщик PDF для Framebuffer. Я хотел бы скомпилировать его, но у меня нет большого успеха, хотя я установил все зависимости ... Ошибка, которую я получаю: $ / ...
вопрос задан: 17 June 2012 11:12
7
ответов

Каков правильный способ установки темы Adwaita на Ubuntu 12.04? [Дубликат]

Я хочу иметь тему Adwaita на Ubuntu 12.04. На моей предыдущей установке я получил это в единстве сразу после установки оболочки gnome3. В приложениях Gtk2 не было вкладок, таких как ожидалось в Gtk3 и ...
вопрос задан: 14 October 2011 18:32
2
ответа

Как я могу использовать тему Synaptic Manager?

Я использую Lubuntu 12.04 и тему gtk2, Elegant Arch. С такой темой приложения gtk2, такие как Thunar, будут тематическими, в то время как другие, такие как Nautilus, не будут (см. Этот вопрос против изображений там) ....
вопрос задан: 13 April 2017 12:24
2
ответа

Не удалось установить libgtk2.0-dev на ubuntu 16.04

При установке libgtk2.0-dev я получаю следующую ошибку: Чтение списков пакетов ... Готово Создание дерева зависимостей Чтение информации о состоянии ... Выполнено Некоторые пакеты не могут быть установлены. ...
вопрос задан: 21 February 2017 14:29
2
ответа

Force LibreOffice 5.1.2.2 использовать gtk2 вместо gtk3?

У меня есть LibreOffice Версия: 5.1.2.2, Build ID: 1: 5.1.2-0ubuntu1 работает на Lubuntu 16.04 LTS. По умолчанию используется gtk3, но я хочу знать, могу ли я переключить его на gtk2 вместо этого, как было намечено комментарием # 7 в ...
вопрос задан: 1 May 2016 15:38
1
ответ

ошибка python и opencv

У меня есть некоторые ошибки с python3, когда я хочу использовать opencv. Он хорошо работает с python2, но не с python3. import cv2 import numpy как np img = cv2.imread ('test.jpg') print (img) cv2.imshow ('image', img) ...
вопрос задан: 18 March 2017 14:35
1
ответ

Значок рабочего стола на рабочем столе - это смещение по порядку

Я не уверен, где мне нужно, чтобы настроить этот значок, который до сих пор смещен. См. Снимок экрана ниже: Я использую Xubuntu 16.04 64-бит с темой Arc и Paper icon theme. EDIT: Это происходит ...
вопрос задан: 17 July 2016 05:49
1
ответ

Отдельные наборы значков для приложений GTK + 2 и GTK + 3 на Kubuntu

Я использую тему Breeze Dark на Kubuntu, которая также отлично работает с приложениями GTK + 2, но она еще не полностью поддерживается в приложениях GTK + 3, таких как Firefox. Из-за этого я установил свою систему ...
вопрос задан: 29 June 2016 22:25
1
ответ

Почему у меня установлены две версии gtk?

Используя следующую команду, чтобы узнать, какую версию gtk использует моя система: политика apt-cache libgtk2.0-0 libgtk-3-0 В ней сказано: libgtk2.0-0: Installed: 2.24.27-0ubuntu1 Кандидат: 2.24.27- 0ubuntu1 ...
вопрос задан: 14 January 2016 19:45
1
ответ

Какова цель / usr / share / themes / Raleigh?

Lubuntu 14.04.3 LTS полностью обновлено. Какую цель выполняет папка Raleigh? $ ls -AlR / usr / share / themes / Raleigh / usr / share / themes / Raleigh: всего 4 drwxr-xr-x 2 root root 4096 24 сентября 06:32 gtk-2.0 ...
вопрос задан: 10 December 2015 05:38
1
ответ

Запустить скрипт Python с привилегиями root (не с терминала)

Как я могу запустить скрипт Python, который после выполнения вызывает диалог, запрашивающий пользователя для его пароля root, так что скрипт запускается как root, способный вносить изменения в файлы в файле / ......
вопрос задан: 27 June 2015 15:54
1
ответ

LispWorks PE (установка) на Ubuntu 14.10 (64 бит)

У меня проблема с личным изданием и запуском на UBUNTU 14.10 (64 бит). Спасибо за ваш совет. Мои шаги по установке: Загруженные файлы с главной страницы lispworks: lwlper-licence.sh, ...
вопрос задан: 5 April 2015 07:28
1
ответ

Ошибка сборки gimp-источника g_module_build_path

Я пытаюсь построить gimp 2.8 из источника, все зависимости - это я, но теперь, если «make» на нем он дает эту ошибку: /i386-linux-gnu/libgtk-x11-2.0.so: error: undefined reference to. ..
вопрос задан: 26 March 2015 18:30
1
ответ

Использование тем в репозитории (14.04)

У Ubuntu единственное средство настройки - только три темы: Ambiance, Highcontrast и Radiance. Кажется, что в хранилище несколько тихих. Я установил gnome-themes-ubuntu через Synaptic. Описание ...
вопрос задан: 25 April 2014 00:51
1
ответ

Согласованность меню GTK2 с GTK3

Как упоминалось в OMG! Ubuntu! почта, меню и панели инструментов приложений GTK3 фиксируются в темах Ubuntu. Но в Ubuntu по-прежнему существует несогласованность между меню GTK2 и GTK3, где приложения GTK2 не ...
вопрос задан: 24 December 2013 09:08
1
ответ

PyGTK 2 GTK 2 альтернатива STYLE_CLASS_PRIMARY_TOOLBAR

В стиле контекста панели инструментов GTK3 может быть установлен Gtk.STYLE_CLASS_PRIMARY_TOOLBAR, чтобы он выглядел как родной в Ubuntu, но в GTK2 нет метода Toolbar.get_style_context () и нет ...
вопрос задан: 7 August 2013 17:36
1
ответ

Приложения GTK2 не правильны

На моей машине Ubuntu 13.04 внезапно все приложения GTK2 (например, Firefox, LibreOffice и т. Д.) Больше не имеют тематики (я использую тему стандартного Ubuntu). Вместо этого они показаны с этим уродливым старым ...
вопрос задан: 22 July 2013 00:13
1
ответ

config не может найти libgtk2

Я попытался установить PCSXR из codeplex, так как версия программного центра не будет работать для меня. Когда я использовал команду ./configure, в итоге он обнаружил ошибку при поиске GTK2: проверка на ...
вопрос задан: 28 June 2013 23:33
1
ответ

Программы выглядят уродливо с темой ClearLooks-Phenix, как исправить?

Некоторые программы в Firefox, похоже, становятся незатронутыми, когда я использую ClearLooks-Phenix на Ubuntu 13.04. Это не произошло 12.04, и, похоже, это вызвало некоторое обновление. То, что могло стать причиной его?
вопрос задан: 19 May 2013 10:26
1
ответ

Измените полосу прокрутки gtk-2 на что-то вроде полосы прокрутки наложения (по внешнему виду)

Когда на чашках имеются колесики прокрутки на мыши и функции прокрутки, малопрозрачная широкая полоса прокрутки не имеет смысла. Поэтому я хотел изменить полосу прокрутки gtk-2.0 на что-то вроде наложения ...
вопрос задан: 18 September 2012 21:55
1
ответ

Как установить резервную копию для темы GTK +?

Я искал способ применить пользовательскую тему GTK3 для каждого приложения, как это можно сделать с помощью GTK2, но похоже, что это невозможно, так как здесь есть открытые вопросы, которые не были решены. ...
вопрос задан: 5 September 2012 18:01
0
ответов

Ошибка Windows Ubuntu GTK2 при установке

Я попытался пару раз установить gtk2 в моем Windows Ubuntu. Я всегда получаю эту ошибку! Err: 1 http://122.2.223.45:80/data/009b6b9058f97580/archive.ubuntu.com/ubuntu bionic / main amd64 libgif7 amd64 5 ....
вопрос задан: 26 May 2018 10:15
0
ответов

Как получить нормальный оранжевый цвет Ubuntu в строке заголовка окна, используя тему Human-Clearlooks?

У меня установлен UBuntu MATE 18.04 LTS. Раньше я получил эту проблему на MATE 17.10. Мне нравится старомодная тема Human-Clearlooks, поэтому я установил пакет человеко-темы. Но у него странное серебро ...
вопрос задан: 5 May 2018 16:47