88
ответов

Что такое ppa: ondrej / php [duplicate]

Я использую Ubuntu 17.10, а php7.0 больше не поддерживается по умолчанию (по умолчанию используется php7.1). Поэтому, чтобы установить php7.0 на Ubuntu 17.10, мне нужно добавить следующее: sudo add-apt -...
вопрос задан: 13 April 2017 15:24
26
ответов

HTTP2 на Ubuntu 17.04, не работающей

Я установил Ubuntu 17.04 на своем ПК, Apache установки с PHP 7 для работы над некоторыми разработками, но когда я пытался установить HTTP2 на своем Apache, это не будет работать, потому что это не установка для Apache, работающего mpm-...
вопрос задан: 15 October 2017 16:10
20
ответов

Попытка установить php-zip - получение зависимостей libzip4 (& gt; = 1.0), даже если у меня установлен 1.0.1

Я пытаюсь установить плагин php zip, который я запускаю: sudo apt-get install php-zip (также php7.0-zip) Я получаю зависимость отсутствия возврата для libzip4 (> = 1.0), но когда я пытаюсь установить или обновить. ..
вопрос задан: 8 July 2017 02:22
18
ответов

Я хочу установить laravel на Ubuntu 16.04 [duplicate]

Я установил лампу (в которой php7 доступен) в нашем Ubuntu 16.04. Теперь я хочу установить Laravel. Как я могу это сделать (шаг за шагом)?
вопрос задан: 8 October 2017 15:31
12
ответов

PHP 7.2 fastcgi не работает на сервере Ubuntu 18.04

Я только что установил LAMP на сервере Ubuntu 18.04, и я не могу заставить PHP fastcgi работать. Вот мои настройки: Мой файл fpm PHP: /etc/php/7.2/fpm/pool.d/sites.mydomain.conf [sites.mydomain] ... user = ...
вопрос задан: 30 April 2018 08:01
9
ответов

Установите Laravel 5 на Ubuntu 16.04

Кто-нибудь устанавливал laravel 5 на Ubuntu 16.04? Я только что перешел на Ubuntu 16.04 и пытаюсь установить на него фреймворк laravel 5 с помощью composer. Но каждый раз, когда я пытаюсь создать проект, это дает ...
вопрос задан: 8 October 2017 15:31
8
ответов

После обновления с 17.04 по 17.10 PHP не запускался [dубликат]

После обновления с 17.04 по 17.10 PHP не запускался: & lt;? Php phpinfo ();? & Gt; не имеет выхода. Как я могу решить эту проблему?
вопрос задан: 31 October 2017 15:06
8
ответов

php.ini не существует

Нет php.ini после установки php (7.1) на ubuntu 16.04 Я установил php, используя apt install php. Я уже пытался найти php.ini с помощью команды find, но нет файла php.ini ...
вопрос задан: 2 June 2017 17:57
8
ответов

Как установить PHP 7?

Вчера вышел PHP 7, и я хотел бы попробовать. PHP 7.0.0 поставляется с новой версией Zend Engine, многочисленными усовершенствованиями и новыми функциями, такими как улучшенная производительность: PHP 7 ...
вопрос задан: 13 July 2016 02:45
7
ответов

Official Docker image for Убунту Сервер?

All I could find is an official Docker image for Убунту Десктоп on Доккер Уб. Isn't there one for Убунту Сервер? Does that мочатся, гd have to поверьте my own базовый image using scratch?
вопрос задан: 8 December 2015 23:31
6
ответов

Попытка установить apache, но он говорит & ldquo; пакет apache2 недоступен & rdquo;

sudo apt install apache2 Чтение списков пакетов ... Готово Создание дерева зависимостей Чтение информации о состоянии ... Готово Пакет apache2 недоступен, но упоминается другим пакетом. Эта ...
вопрос задан: 30 March 2018 19:55
6
ответов

Как установить php7.1 на Ubuntu 16.04 без Apache?

Установка php7.1 с помощью этой команды: sudo apt-get install -y software-properties-common sudo add-apt-repository -y ppa: ondrej / php sudo apt-get update sudo apt-get install -y php7.1 #Modules судо ...
вопрос задан: 22 December 2017 01:59
6
ответов

Невозможно загрузить динамическую библиотеку '/usr/lib/php/20151012/php_xmlrpc.dll'

Я установил Apache 2.4, PHP7 и установил SimpleXML, используя: apt-get install php-simplexml. Затем я раскомментировал строку в php.ini для расширения = php_xmlrpc.dll и перезапустил Apache. Мой апач ....
вопрос задан: 12 September 2017 19:23
6
ответов

ОШИБКА: Модуль php7.0 не существует!

У меня установлен Ubuntu Server 16.04 с Webmin 1.831. Я получаю эту ошибку при попытке запустить PHP ERROR: модуль php7.0 не существует. Установлен libapache2-mod-php7.0.
вопрос задан: 7 May 2017 05:35
6
ответов

Предупреждение PHP: Запуск PHP: невозможно загрузить динамическую библиотеку

Я получил сообщение об ошибке, похожее на предупреждение PHP: Запуск PHP: невозможно загрузить динамическую библиотеку '/usr/lib/php/20151012/php_intl.dll' - /usr/lib/php/20151012/php_intl.dll: не удается открыть файл общего объекта: нет такой файл или ..
вопрос задан: 9 June 2016 18:25
5
ответов

Как установить расширение Mongodb PHP в Ubuntu 16.04 LTS

Я использую Ubuntu 16.04 LTS и хочу использовать Mongodb с PHP. Для этого я попробовал sudo apt-get install php5-mongo, чего достаточно для Ubuntu 14.04 LTS, но я ошибаюсь. Я получаю ...
вопрос задан: 20 March 2019 15:29
5
ответов

PHP 7.2 fastcgi не работает над сервером Ubuntu 18.04

Я только что установил ЛАМПУ на сервере Ubuntu 18.04, и я не могу заставить PHP fastcgi работать. Вот мои настройки: Мой fpm PHP файл:/etc/php/7.2/fpm/pool.d/sites.mydomain.conf [sites.mydomain]... пользователь =...
вопрос задан: 29 April 2018 22:01
5
ответов

localhost / phpmyadmin не работает на Ubuntu 16.04

недавно установил свежую Ubuntu 16.04 удалив Ubuntu 14.04. Я пытаюсь настроить LAMP на локальной машине и установил PHP7.0, mySql и phpMyadmin. Все работает нормально, http: // localhost is ...
вопрос задан: 22 April 2016 21:55
4
ответа

Как установить ImageMagick для PHP7 на Ubuntu?

Что ж, сразу после обновления Ubuntu и, следовательно, перехода на php7, я не могу установить расширение imagick для php, используя ту же старую команду sudo apt-get install php5-imagick. Я получаю следующее ...
вопрос задан: 26 November 2018 10:23
4
ответа

** curl ** не работает на Ubuntu 18.04 LTS

Я не могу получать контент из Интернета с помощью curl. Я попытался установить его ниже. Некоторые пакеты не могут быть установлены. Это может означать, что вы запросили невозможную ситуацию или если ...
вопрос задан: 7 May 2018 10:28
4
ответа

Apt get install php7.1-dev расширение не работает

Я запускаю Ubuntu 17.04 с PHP 7.1, я пытаюсь установить расширение PHP dev, но он не найден: [17:21:43] @ Z240: ~ / workspace / api $ sudo apt install php7.1-dev Лекция des listes de paquets ... ...
вопрос задан: 1 March 2018 20:55
4
ответа

Команда php -v не показывает правильную версию на ubuntu 17.10

При использовании команды php -v я получил следующий результат. PHP 7.2.1-1 + ubuntu17.10.1 + deb.sury.org + 1 (cli) (построено: 5 января 2018 13:55:19) (NTS) Copyright (c) 1997-2017 PHP Group Zend Engine v3. 2.0, ...
вопрос задан: 18 January 2018 18:59
4
ответа

Как обновить версию php в Lampp в Ubuntu

Мне нужно обновить версию php до 7.2 в моем Lampp. На самом деле, когда я проверяю php -v в терминале, он показывает следующий результат: PHP 7.2.1-1 + ubuntu14.04.1 + deb.sury.org + 1 (cli) (построено: 11 января ...
вопрос задан: 18 January 2018 17:11
4
ответа

Ubuntu 16.04 с PHP7.0 и ISPconfig

Я уверен, что сервер работает нормально даже после обновления с 14.04, однако теперь, когда мне нужно выполнить обновление ispconfig, я обнаружил, что PHP CLI - это более старая версия. Я удалил любые другие экземпляры ...
вопрос задан: 20 June 2017 23:41
4
ответа

php.ini не существует

Нет никакого php.ini после установки php (7.1) на установленном php ubuntu 16.04 I использование способной установки php. Я уже попытался найти php.ini с помощью команды находки, но нет никакого файла под названием php.ini...
вопрос задан: 2 June 2017 17:57
4
ответа

как включить и отключить php7 модули в сервере Linux 16.4

Я имею безумный пользовательские ini файлы в/etc/php/7.0/mods-available. как я могу включить его. Я попробовал php5enmod и php7enmod. ни один не работал на меня.Спасибо.
вопрос задан: 21 November 2016 02:01
4
ответа

Перезапуск Apache2 перестал работать в Ubuntu 16.04

Я пытаюсь использовать домен для своего localhost вместо localhost, или 127.0.0.1 я добавил конфигурационный файл myconfig.conf в сайтах-availbale, которые я также включил ему с помощью sudo a2ensite myconfig....
вопрос задан: 26 May 2016 13:07
4
ответа

Установка PHP 5.6 на Xenial (16.04) [дубликат]

Мне нужно использовать php5 (5.6), потому что я работаю над проектом Drupal 7, который не поддерживает php7. Проблема в том, что я недавно обновился до Ubuntu 16.04 Xenial, который, похоже, больше не поддерживает php5. Я пытался ...
вопрос задан: 13 May 2016 20:05
4
ответа

Как установить расширение Mongodb PHP в Ubuntu 16.04 LTS

Я запускаю Ubuntu 16.04 LTS, и я хочу использовать Mongodb с PHP. Для этого я подумал, что sudo apt-get install php5-mongo (которого достаточно для Ubuntu 14.04 LTS) будет достаточно, но я ошибся. Я ...
вопрос задан: 30 April 2016 00:01
4
ответа

PHP, представленный как текст после обновления Ubuntu 16.04

Apache представляет файлы PHP как текст после обновления Ubuntu 16.04. Apache установлен и выполнение. PHP7 работает. Когда я выполняю следующую команду, я получаю корректный вывод: php-r 'отзываются эхом "\n\...
вопрос задан: 24 April 2016 14:56