ncurses-base: Перерывы: libtinfo5 (<6.1), но необходимо установить 6.0 + 20160213-1ubuntu1 [закрыто]

Я пытался обновить свой POPOS 19.04 и получил это сообщение. Что мне делать?

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
    ncurses-base : Breaks: libtinfo5 (< 6.1) but 6.0+20160213-1ubuntu1 is to be installed
E: Broken packages
0
задан 14 August 2020 в 07:41

1 ответ

Решение:

Чтобы решить эту проблему, нажмите Ctrl + Alt + T, чтобы открыть терминал, и попробуйте выполнить одну из следующих команд:

sudo apt-get clean

или,

sudo apt-get autoclean

Одно из самых основных исправлений для решения проблем с зависимостями - запустить:

sudo apt-get -f install

-f здесь означает « исправление сломано ». Apt попытается исправить сломанные зависимости. Если вы вручную установили пакет, у которого были неудовлетворенные зависимости, apt-get установит эти зависимости, если это возможно, в противном случае он может просто удалить установленный вами пакет, чтобы решить проблему.

Затем запустите:

sudo dpkg --configure -a

Затем запустите еще раз:

sudo apt-get -f install

Если вывод:

0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Это означает, что произошел сбой.

Следующее решение - запустить:

sudo apt-get -u dist-upgrade

Если он показывает какие-либо задержанные пакеты, лучше их удалить. Пакеты удерживаются из-за конфликтов зависимостей, которые apt не может разрешить. Попробуйте эту команду, чтобы найти и устранить конфликты:

sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade

Если она не может исправить конфликты, она выйдет с:

0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.

Удалять удерживаемые пакеты один за другим, каждый раз выполняя dist-upgrade, пока не останутся все удерживаемые пакеты . Затем переустановите все необходимые пакеты. Обязательно используйте опцию - пробный запуск , чтобы вы были полностью осведомлены о последствиях:

sudo apt-get remove --dry-run package-name
0
ответ дан 21 August 2020 в 07:59

Другие вопросы по тегам:

Похожие вопросы: