Как часто ubuntu обновляет свои версии python после CVE? [дубликат]

Python3 версии до февраля 16 года. 2021 имеет уязвимость (CVE 2021-3177) . Я вижу, что текущая версия python3.7 на ubuntu 18.04 составляет 3.7.5. CVE зафиксирован в питоне 3.7.10.

Как это обычно происходит? Будет ли ubuntu обычно создавать новый пакет с python 3,7,10, который имеет исправление, или пользователи обычно компилируют из источника или используют pyenv, если они хотят последнюю версию?

-121--889549- Как получить средство просмотра изображений с поддержкой JPEG 2000? Я работал с партиями JPEG 2000 (.jp Это было бы гораздо удобнее, если бы у меня был зритель изображений, способный отображать изображения JPEG 2000 вместо того, чтобы преобразовывать их...

Недавно я работал с пакетами файлов JPEG 2000 (.jp2). Это было бы гораздо удобнее, если бы я имел средство просмотра изображений, способное отображать изображения JPEG 2000 вместо того, чтобы преобразовывать их в файлы TIF, чтобы видеть их содержимое.

Из того, что я видел, ни одно программное обеспечение для просмотра изображений или управления фотографиями, найденное в хранилищах Ubuntu 20,04, не поддерживает файлы JPEG 2000, предположительно из-за потенциальных патентных проблем с форматом. Версия GIMP, представленная в 20.04, способна нативно открывать файлы JPEG 2000, но это полноценный редактор изображений и недостаточно быстрая/удобная замена для просмотра изображений.

Как получить J2K-capable средство просмотра изображений на Ubuntu 20.04.1? Я хотел бы избежать Snaps и неофициальных PPA, если это вообще возможно. Я готов строить вещи из источника, если это необходимо (я предполагаю, что это будет в этой ситуации), но хотел бы избежать необходимости также строить длинный список зависимостей. Построение с поддержкой только JPEG 2000 также будет нормально, так как я, вероятно, настрою это средство просмотра только на открытие JP2-файлов.

Меня интересует только программное обеспечение FOSS.

2
задан 27 February 2021 в 10:52

2 ответа

Я наткнулся на пакет Geeqie при проверке обратных зависимостей пакета libopenjp2-7 на Ubuntu 20.10.

К сожалению в Ubuntu 20.04 Geeqie не зависит от этого пакета и не будет поддерживать файлы JP2-файлов.

Но вы можете попытаться установить более новую версию Geeqie, здесь Вы найдете подробную информацию о том, как это сделать.

Кроме того, вы можете попробовать вручную загрузить и устанавливать пакеты Geeqie и Geeqie-Common от 20.10-репозитория.

1
ответ дан 18 March 2021 в 23:31

Это возможно любой просмотра изображений, который использует библиотеку OpenJPEG2 .

Возможный кандидат темно-кандидат из Darktable пакета .

0
ответ дан 18 March 2021 в 23:31

Другие вопросы по тегам:

Похожие вопросы: