HPLIP не будет установлен 20.04 из-за Python 3 ( что делать?)

Я пытаюсь установить последнюю версию HPLIP, следуя этому руководству . Подводя итог, вы выполните следующее:

sudo apt-get purge hplip hplip-data hplip-doc hplip-gui hpijs-ppds libsane-hpaio printer-driver-hpcups printer-driver-hpijs

sudo rm -rf /usr/share/hplip/

sudo apt-get autoremove

Затем вы загружаете последнюю версию HPLIP и устанавливаете через это руководство (то есть sh hplip-3.20.2.run и принимаете все значения по умолчанию). Я устанавливаю на Ubuntu 20.04, который, по моему мнению, использует Python 3, а не Python 2. Похоже, что по этой причине программа установки HPLIP выдает ошибку:

...
проверка python2.7m ... нет
...
ошибка: не удается найти поддержку python-devel

Является ли единственным выходом из этой проблемы для переключения моей установки 20.04 на версию Python 2 ? Я бы предпочел оставить эту установку 20.04 на Python 3.

0
задан 31 July 2020 в 16:58

1 ответ

Вы всегда можете установить python2, запустив

sudo apt install python2

Это ничего не изменит с python3.

2
ответ дан 2 August 2020 в 22:00

Другие вопросы по тегам:

Похожие вопросы: