Bluetooth не работает часто в 20.04

Я использую наушники Powerbeats 3 через Bluetooth на своем рабочем столе, и каждые 2 дня после загрузки я обнаруживаю, что отлаживаю, почему мои наушники больше не подключаются.

Я использовал следующие вопросы и ответы на них каждый раз, когда мог:

Некоторые ответы иногда работают, а иногда и их комбинация из них и перезагрузка моей системы, кажется, волшебным образом помогает.

Симптомы моих наушников больше не подключаются через Bluetooth:

  • Используя графический интерфейс, при нажатии на кнопку включения / выключения подключения, чтобы включить его, они сразу же выключаются .
  • Используя bluetoothctl, удалив устройство,снова доверяю устройству и пытаясь выполнить сопряжение, оно просто продолжается до тех пор, пока оно не выходит из строя из-за того, что мое устройство выключается и так долго пытается выполнить сопряжение.

Может быть связано с некоторыми из этих пакетов:

  • bluez 5.53
  • libbluetooth3 5.53

Мне нужна помощь в отладке этой проблемы, думаю, я устал перезагружать несколько раз каждые несколько дней только для того, чтобы мои наушники заработали.

Изменить: я использую адаптер bluetooth tp link ub 400.

Результат "lsusb":

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 003 Device 003: ID 1b1c:1b20 Corsair Corsair STRAFE RGB Gaming Keyboard
Bus 003 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

1
задан 9 August 2020 в 18:09

1 ответ

К сожалению, TP-Link UB400 не поддерживает Linux.

TP-Link website

См. Этот веб-сайт: https://www.tp-link.com/us/support/faq/2744 /

В официальной документации Ubuntu упоминается, что:

Некоторые адаптеры Bluetooth не поддерживаются в Linux, поэтому вы не сможете получить для них нужные драйверы. В этом случае вам, вероятно, придется приобрести другой адаптер Bluetooth.

Ubuntu documentation

См. Этот сайт: https://help.ubuntu.com/stable/ubuntu-help/bluetooth-problem-connecting.html.en

Думаю, лучше всего выбрать адаптер Bluetooth, поддерживающий Linux.

1
ответ дан 11 August 2020 в 20:10

Другие вопросы по тегам:

Похожие вопросы: