Попытка обновить python3.9 дает ошибки

Что я сделал:

sudo add-apt-repository ppa:deadsnakes/ppa
sudo apt update
sudo apt install python3.9
sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.8 1
sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.9 2

python --version

Теперь у меня несколько ошибок, я не могу запустить терминатор или обновить, когда я запускаю терминал помощника, у меня появляется эта ошибка:

/usr/bin/screenfetch: /usr/bin/lsb_release : /usr/bin/python3 : mauvais interpréteur: Aucun fichier ou dossier de ce type

Когда я актуализирую с synaptic У меня есть эта ошибка:

E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code

Все эти ошибки начались с установки python, как я описал в начале.

0
задан 18 December 2020 в 17:46

0 ответов

Другие вопросы по тегам:

Похожие вопросы: