Как восстановить разрушенные пакеты?

Я хотел установить LMMS (музыкальный инструмент с открытым исходным кодом), использовал apt для его установки.

sudo apt-get install lmms

Однако он показал , что эти пакеты будут удалены text. На самом деле он показал множество пакетов. Тогда я сказал: да ладно, по крайней мере тысячи людей скачали таким образом. Но он действительно пытался удалить все, я не знаю почему.

Мне удалось это остановить. Но он удалил множество пакетов.

Это результат работы cat /var/log/dpkg.log | grep remove

2020-12-27 12:50:41 startup packages remove
2020-12-27 12:50:41 remove albert:amd64 0.17.2-0 <none>
2020-12-27 12:50:42 remove alsa-tools-gui:amd64 1.1.7-1ubuntu1 <none>
2020-12-27 12:50:42 remove apport-gtk:all 2.20.11-0ubuntu27.8 <none>
2020-12-27 12:50:43 remove nautilus-share:amd64 0.7.3-2ubuntu3 <none>
2020-12-27 12:50:44 remove apturl:amd64 0.5.2ubuntu19 <none>
2020-12-27 12:50:45 remove ubuntu-desktop:amd64 1.450.2 <none>
2020-12-27 12:50:46 remove ubuntu-desktop-minimal:amd64 1.450.2 <none>
2020-12-27 12:50:46 remove orca:all 3.36.2-1ubuntu1~20.04.1 <none>
2020-12-27 12:50:48 remove python3-pyatspi:all 2.36.0-1 <none>
2020-12-27 12:50:48 remove at-spi2-core:amd64 2.36.0-2 <none>
2020-12-27 12:50:49 remove baobab:amd64 3.34.0-1 <none>
2020-12-27 12:50:50 remove brltty:amd64 6.0+dfsg-4ubuntu6 <none>
2020-12-27 12:50:53 remove cheese:amd64 3.34.0-1build1 <none>
2020-12-27 12:50:54 remove chrome-gnome-shell:all 10.1-5 <none>
2020-12-27 12:50:54 remove gdm3:amd64 3.34.1-1ubuntu1 <none>
2020-12-27 12:50:56 remove ubuntu-session:all 3.36.0-2ubuntu1 <none>
2020-12-27 12:50:56 remove gnome-startup-applications:amd64 3.36.0-2ubuntu1 <none>
2020-12-27 12:50:57 remove gnome-session-bin:amd64 3.36.0-2ubuntu1 <none>
2020-12-27 12:50:58 remove shotwell:amd64 0.30.10-0ubuntu0.1 <none>
2020-12-27 12:50:58 remove nautilus-extension-gnome-terminal:amd64 3.36.2-1ubuntu1~20.04 <none>
2020-12-27 12:50:59 remove xorg:amd64 1:7.7+19ubuntu14 <none>
2020-12-27 12:51:00 remove gnome-terminal:amd64 3.36.2-1ubuntu1~20.04 <none>
2020-12-27 12:51:00 remove dbus-x11:amd64 1.12.16-2ubuntu2.1 <none>
2020-12-27 12:51:01 remove dconf-editor:amd64 3.36.0-1 <none>
2020-12-27 12:51:02 remove deja-dup:amd64 40.7-0ubuntu1 <none>
2020-12-27 12:51:03 remove eog:amd64 3.36.3-0ubuntu1 <none>
2020-12-27 12:51:05 remove evince:amd64 3.36.7-0ubuntu1 <none>
2020-12-27 12:51:06 remove update-notifier:amd64 3.192.30 <none>
2020-12-27 12:51:07 remove update-manager:all 1:20.04.10.1 <none>
2020-12-27 12:51:08 remove ubuntu-release-upgrader-gtk:all 1:20.04.25 <none>
2020-12-27 12:54:25 startup packages remove
2020-12-27 12:54:25 remove apturl-common:amd64 0.5.2ubuntu19 <none>
2020-12-27 12:54:26 remove duplicity:amd64 0.8.11.1612-1 <none>
2020-12-27 12:54:27 remove evince-common:all 3.36.7-0ubuntu1 <none>
2020-12-27 12:54:28 remove libpam-fprintd:amd64 1.90.1-1ubuntu1 <none>
2020-12-27 12:54:29 remove fprintd:amd64 1.90.1-1ubuntu1 <none>
2020-12-27 12:54:30 remove gnome-session-common:all 3.36.0-2ubuntu1 <none>
2020-12-27 12:54:31 remove gnome-terminal-data:all 3.36.2-1ubuntu1~20.04 <none>
2020-12-27 12:54:33 remove libfprint-2-2:amd64 1:1.90.2+tod1-0ubuntu1~20.04.1 <none>
2020-12-27 12:54:34 remove libglu1-mesa:amd64 9.0.1-1build1 <none>
2020-12-27 12:54:35 remove libmuparser2v5:amd64 2.2.6.1+dfsg-1build1 <none>
2020-12-27 12:54:35 remove libpcre2-32-0:amd64 10.34-7 <none>
2020-12-27 12:54:36 remove libqt5concurrent5:amd64 5.12.8+dfsg-0ubuntu1 <none>
2020-12-27 12:54:37 remove libqt5sql5-sqlite:amd64 5.12.8+dfsg-0ubuntu1 <none>
2020-12-27 12:54:37 remove libqt5sql5:amd64 5.12.8+dfsg-0ubuntu1 <none>
2020-12-27 12:54:38 remove libraw19:amd64 0.19.5-1ubuntu1 <none>
2020-12-27 12:54:39 remove librsync2:amd64 2.0.2-1ubuntu1 <none>
2020-12-27 12:54:39 remove python3-paramiko:all 2.6.0-2 <none>
2020-12-27 12:54:40 remove python3-bcrypt:amd64 3.1.7-2ubuntu1 <none>
2020-12-27 12:54:41 remove python3-brlapi:amd64 6.0+dfsg-4ubuntu6 <none>
2020-12-27 12:54:42 remove python3-fasteners:all 0.14.1-2 <none>
2020-12-27 12:54:43 remove python3-future:all 0.18.2-2 <none>
2020-12-27 12:54:43 remove python3-lockfile:all 1:0.12.2-2ubuntu2 <none>
2020-12-27 12:54:44 remove python3-louis:all 3.12.0-3 <none>
2020-12-27 12:54:45 remove python3-monotonic:all 1.5-0ubuntu2 <none>
2020-12-27 12:54:46 remove python3-speechd:all 0.9.1-4 <none>
2020-12-27 12:54:47 remove shotwell-common:all 0.30.10-0ubuntu0.1 <none>

Я не знаю, как это исправить. Я подумал о том, чтобы вручную переустановить все, используя, aptitude install , но оттуда тоже не повезло.

  ~ sudo aptitude install nautilus-share                  
The following NEW packages will be installed:
  apturl{a} apturl-common{a} dbus-x11{ab} gnome-session-bin{a} gnome-session-common{a} gnome-startup-applications{a} nautilus-share 
0 packages upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 215 kB of archives. After unpacking 1.415 kB will be used.
The following packages have unmet dependencies:
 dbus-x11 : Depends: libdbus-1-3 (= 1.12.16-2ubuntu2) but 1.12.16-2ubuntu2.1 is installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     dbus-x11 [Not Installed]                           
2)     gnome-session-bin [Not Installed]                  
3)     gnome-startup-applications [Not Installed]         
4)     nautilus-share [Not Installed]                     



Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
0
задан 27 December 2020 в 13:23

0 ответов

Другие вопросы по тегам:

Похожие вопросы: