не могу установить php7.0 или 7.1 или 7.2 в Ubuntu 14.04 [закрыто]

У меня проблема с несколько недель назад, может, месяц ... проблема в том, что я пытаюсь установить php версии 7.0 или выше, но не работаю в команде в терминале ...

sudo apt-get установите php7.1 и верните мне это сообщение

root@Myvm:/etc/php# sudo apt-get install php7.2
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'php7.2-phar' for regex 'php7.2'
Note, selecting 'php7.2-sysvsem' for regex 'php7.2'
Note, selecting 'php7.2-posix' for regex 'php7.2'
Note, selecting 'php7.2-sysvshm' for regex 'php7.2'
Note, selecting 'php7.2-gettext' for regex 'php7.2'
Note, selecting 'php7.2-iconv' for regex 'php7.2'
Note, selecting 'php7.2-soap' for regex 'php7.2'
Note, selecting 'php7.2-exif' for regex 'php7.2'
Note, selecting 'php7.2-ctype' for regex 'php7.2'
Note, selecting 'php7.2-sodium' for regex 'php7.2'
Note, selecting 'php7.2-sysvmsg' for regex 'php7.2'
Note, selecting 'php7.2-pdo' for regex 'php7.2'
Note, selecting 'php7.2-fileinfo' for regex 'php7.2'
Note, selecting 'php7.2-mbstring' for regex 'php7.2'
Note, selecting 'php7.2-sockets' for regex 'php7.2'
Note, selecting 'php7.2-shmop' for regex 'php7.2'
Note, selecting 'php7.2-common' for regex 'php7.2'
Note, selecting 'php7.2-calendar' for regex 'php7.2'
Note, selecting 'php7.2-ftp' for regex 'php7.2'
Note, selecting 'php7.2-tokenizer' for regex 'php7.2'
Note, selecting 'php7.2-common' instead of 'php7.2-calendar'
Note, selecting 'php7.2-common' instead of 'php7.2-ctype'
Note, selecting 'php7.2-common' instead of 'php7.2-exif'
Note, selecting 'php7.2-common' instead of 'php7.2-fileinfo'
Note, selecting 'php7.2-common' instead of 'php7.2-ftp'
Note, selecting 'php7.2-common' instead of 'php7.2-gettext'
Note, selecting 'php7.2-common' instead of 'php7.2-iconv'
Note, selecting 'php7.2-common' instead of 'php7.2-pdo'
Note, selecting 'php7.2-common' instead of 'php7.2-phar'
Note, selecting 'php7.2-common' instead of 'php7.2-posix'
Note, selecting 'php7.2-common' instead of 'php7.2-shmop'
Note, selecting 'php7.2-common' instead of 'php7.2-sockets'
Note, selecting 'php7.2-common' instead of 'php7.2-sysvmsg'
Note, selecting 'php7.2-common' instead of 'php7.2-sysvsem'
Note, selecting 'php7.2-common' instead of 'php7.2-sysvshm'
Note, selecting 'php7.2-common' instead of 'php7.2-tokenizer'
php7.2-mbstring is already the newest version.
php7.2-soap is already the newest version.
php7.2-common is already the newest version.
The following packages were automatically installed and are no longer 
required:
linux-headers-3.13.0-160 linux-headers-3.13.0-160-generic
linux-image-3.13.0-160-generic
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Пожалуйста, мне нужно решить эту проблему, мне нужно установить php 7.2 в Ubuntu 14.04 с apache2

Спасибо, ребята !

-4
задан 26 June 2019 в 06:51

1 ответ

Откройте терминал и введите следующие команды:

$ sudo apt-get install software-properties-common<br>

Как описано в apt-show software-properties-common

Это программное обеспечение предоставляет абстракцию используемых репозиториев apt. Это позволяет вам легко управлять дистрибуцией и источниками программного обеспечения независимых поставщиков программного обеспечения.

Далее, включите ondrej / php в Ubuntu Linux 14.04 LTS

$ sudo add-apt-repository ppa:ondrej/php

Обновите индекс пакета

$ sudo apt-get update

Список всех пакетов PHP 7

$ apt-cache search php7

Пример выходных данных

php7.0-common - общие файлы для пакетов, созданных из исходного кода PHP
libapache2-mod-php7.0 - на стороне сервера, встроенный в HTML язык сценариев (модуль Apache 2)
php7.0-cgi - серверный встроенный в HTML язык сценариев (двоичный файл CGI)
php7.0-cli - интерпретатор командной строки для Язык сценариев PHP
php7.0-phpdbg - серверный, встроенный в HTML язык сценариев (двоичный файл PHPDBG)
php7.0-fpm - серверный, встроенный в HTML язык сценариев ( FPM-CGI binary)
libphp7.0-embed - язык сценариев, встроенный в HTML (встроенная библиотека SAPI)
php7.0-dev - файлы для разработки модуля PHP7.0
php7.0-dbg - символы отладки для PHP7.0
php7.0-curl - модуль CURL для PHP
php7.0-enchant - модуль улучшения для PH P
php7.0-gd - модуль GD для PHP
php7.0-gmp - модуль GMP для PHP
php7.0-imap - модуль IMAP для PHP
php7.0-interbase - модуль Interbase для PHP
php7.0-intl - модуль интернационализации для PHP
php7.0-ldap - модуль LDAP для PHP
php7.0-mcrypt - модуль libmcrypt для PHP
php7.0-readline - модуль readline для PHP
php7.0-odbc - модуль ODBC для PHP
php7.0-pgsql - модуль PostgreSQL для PHP
php7.0-pspell - модуль pspell для PHP
php7.0-recode - модуль перекодирования для PHP
php7 .0-snmp - модуль SNMP для PHP
php7.0-tidy - модуль tidy для PHP
php7.0-xmlrpc - модуль XMLRPC-EPI для PHP
php7 .0-xsl - XSL-модуль для PHP
php7.0 - серверный встроенный в HTML язык сценариев (метапакет)
php7.0-json - JSON-модуль для PHP
php-all-dev - пакет, зависящий от всех поддерживаемых PHP-разработок. ckages
php7.0-sybase - модуль Sybase для PHP
php7.0-modules-source - пакет исходного кода модулей PHP 7.0
php7.0-sqlite3 - модуль SQLite3 для PHP
php7.0-mysql - модуль MySQL для PHP
php7.0-opcache - модуль Zend OpCache для PHP
php7.0-bz2 - модуль bzip2 для PHP

Установить PHP 7

$ sudo apt-get install -y php7.0

ИЛИ

$ sudo apt-get install php7.0 php7.0-cli php7.0-fpm php7.0-gd php7.0-json php7.0-mysql php7.0-readline
-2
ответ дан 26 June 2019 в 06:51

Другие вопросы по тегам:

Похожие вопросы: