5967
ответов

Как откат к PHP 5.2?

Я только что установил 10.04 LTS на моем сервере разработки, но система, которую мне нужно запустить на нем (электронная торговля Magento), несовместима с PHP 5.3, которая поставляется с новейшей версией Ubuntu. Является ...
вопрос задан: 8 February 2012 22:41
2600
ответов

Как создать собственный пакет php 5.3.3 / ppa?

Я действительно хотел бы создать пакет для php 5.3.3, а затем сделать ppa для него (я хотел бы поддерживать php-fpm, но в новейшей версии), однако этот вопрос идет дальше этого. Я ...
вопрос задан: 29 July 2010 10:55
110
ответов

Я хочу установить phpmyadmin, но есть проблема? [dубликат]

root @ i-Tech: / home / islam_mesha # sudo apt-get install phpmyadmin php-mbstring php-gettext Чтение списков пакетов ... Готово Создание дерева зависимостей Чтение информации о состоянии ... Готово php-gettext ...
вопрос задан: 23 October 2014 16:43
80
ответов

разрешить apache html как для www-data, так и для пользователя [duplicate]

Я использую функцию mkdir в php, и я использую sudo chown -R www-data: www-data / var / www / html /, чем я могу установить папку mkdir. Но я не могу редактировать любой файл в / var / www / html /. Поэтому я попробовал оба ...
вопрос задан: 1 June 2011 20:32
73
ответа

Как запустить цикл while при запуске системы? [dубликат]

У меня есть php-файл, который я перебираю, чтобы проверить некоторые значения в базе данных, которую я зацикливаю, используя следующую команду bash, в то время как true; делать php cron.php; сон 5; сделано, есть какой-нибудь способ запустить это ...
вопрос задан: 23 November 2016 20:22
72
ответа

Глобальная установка композитора (руководство)

Я выполнил руководство для композитора (глобальная установка композитора (руководство)) для установки композитора на Ubuntu. $ ll / usr / local / bin / total 4760 drwxr-xr-x 2 root root 4096 2012-03-29 08:29 ./ drwxr-xr-x 10 ...
вопрос задан: 29 March 2012 07:40
68
ответов

Как установить curl в php5?

В настоящее время у меня PHP 5.3 установлен с Apache в 10.04 Lucid. Как добавить библиотеки PHP Curl? Нужно ли устанавливать какие-либо другие зависимости для завивки?
вопрос задан: 25 October 2010 04:06
64
ответа

Как я могу принудить пользователя: групповое владение новыми файлами, написанными www-данными apache? [dубликат]

В качестве вежливости мы размещаем файлы веб-сайтов наших клиентов. Каждый клиент имеет свою собственную учетную запись Linux, а файлы веб-сайта подаются из / home / user / public_html. Все файлы клиентов имеют владельцы пользователей: ...
вопрос задан: 1 June 2011 20:32
64
ответа

Получение прав root для чтения и записи файлов в корневой каталог Apache2? [dубликат]

Я использую xenial систему Ubuntu 16.04, для стека LAMP и PHP и т. Д. Мне нужно сохранить / написать PHP-файлы в корневую папку Apache из Sublime Text3, но у меня нет разрешения, это всегда требует от меня. ,
вопрос задан: 1 June 2011 20:32
64
ответа

не могу сохранить ничего в var / www / html [duplicate]

Im работает apache2 на моем ubuntu 14.04 Я не могу ничего сохранить в моей папке var / www / html, что мне нужно делать? Когда я создаю файл с gedit im, способным переместить его в var / www / html, но он появляется ...
вопрос задан: 1 June 2011 20:32
56
ответов

root как владелец www-data [duplicate]

Iam php-разработчик, запускающий apache в среде разработки (персональный компьютер с ubuntu) ... Проблема в том, что Im программирует пурпурные расширения, поэтому каждый момент я должен делать chmod -R 777. в ...
вопрос задан: 1 June 2011 20:32
55
ответов

Как обновить PHPmyAdmin [повторно]

Этот вопрос задавался ранее. Как обновить PHPmyAdmin. Ответ был подтвержден sudo apt-get update sudo apt-get install phpmyadmin или sudo apt-get update sudo apt-get upgrade. Версия ...
вопрос задан: 21 August 2017 07:22
54
ответа

Как перейти на определенную версию PHP?

У меня установлена ​​установка Ubuntu 10.04 Server с установленным PHP 5.3.2, я хочу обновить ее до PHP 5.3.5. Я убежден, что apt-get upgrade установит только обновления безопасности, мы на этом LTS ...
вопрос задан: 30 April 2012 15:57
47
ответов

Обновление PHP с 5.3.2 до 5.3.6

Я использую Ubuntu 10.04. И я хочу обновить свою версию php. Когда я обновляю свою версию PHP (5.3.2 до 5.3.6), но после каждого обновления его показать PHP версии 5.3.2 .. Edit :: Я проверил «Ubuntu ...
вопрос задан: 27 April 2011 06:19
45
ответов

Поиск программного обеспечения для редактирования кода со следующими функциональными возможностями

Я ищу текстовый редактор со следующими функциями для кодирования php, html и css: сворачивание кода на основе отступа (лучший пример - EditPlus) начинается с уровня отступа и останавливается ...
вопрос задан: 26 July 2011 13:40
44
ответа

PHP не работает после обновления до Ubuntu 17.10

После того как я обновился до Ubuntu 17.10, PHP полностью прекратил работать. Все отлично работает в Ubuntu 17.04. Код для info.php следующим образом не работает: & lt;? Php phpinfo (); ? & GT; Он не показывает ...
вопрос задан: 31 October 2017 12:06
40
ответов

Обновите версию PHP до 5.3 на Ubuntu

Как я могу выполнить обновление версии с 5.2 до 5.3? Обновление / обновление php говорит, что я использую последнюю версию. Я использую Ubuntu Server 9.04
вопрос задан: 8 February 2011 19:02
37
ответов

Ошибки зависимостей после попытки установки php7.0-cli [duplicate]

во-первых, я настоящий новичок в Linux, и я только что установил ubuntu 16.4 на моем 64-битном IdePad 110, и вот в чем проблема. Я пытался установить php с помощью этой команды, sudo apt-get ...
вопрос задан: 18 April 2018 17:38
36
ответов

Как установить wkhtmltopdf на Ubuntu 16.04 (armhf) [duplicate]

Я пытаюсь установить wkhtmltopdf на моем сервере масштабирования Ubuntu 16.04. Я нашел этот учебник онлайн о том, как его установить. Проблема в том, что я застрял на шаге 3: я получаю следующую ошибку: sudo ...
вопрос задан: 25 September 2017 08:00
36
ответов

php.ini не существует

Нет php.ini после установки php (7.1) на ubuntu 16.04 Я установил php, используя apt install php. Я уже пытался найти php.ini с помощью команды find, но нет файла php.ini ...
вопрос задан: 2 June 2017 14:57
36
ответов

Запуск сценариев PHP7 на сервере приведет к загрузке файла вместо отображения содержимого [duplicate]

Может кто-то мне помочь, пожалуйста? Я запускаю тестовый php-скрипт с phpinfo внутри. Когда я запускаю его на локальном сервере, вместо отображения чего-либо, он просит меня загрузить. Я сделал дюжину вещей ...
вопрос задан: 6 April 2016 16:41
36
ответов

Как обновить до PHP 5.3.10 в 10.04?

Я новичок в Linux и имею только базовый опыт работы с Ubuntu и установкой LAMP Server. Я успешно установил все, используя метод apt-get install. Моя проблема в том, что я хочу обновить PHP 5.3.2 ...
вопрос задан: 7 February 2012 08:17
36
ответов

Как работать на * .php страницах без LAMP

Я изучаю PHP, а это значит, что мне нужно будет установить LAMP на моем ноутбуке, и я думаю, что LAMP снизит время автономной работы, которое уже очень низкое. Так что замените LAMP, чтобы я мог видеть, как ...
вопрос задан: 8 December 2010 13:18
33
ответа

Пакет php-mcrypt отсутствует на сервере Ubuntu 18.04 LTS

Является ли пакет php-mcrypt отсутствующим в Ubuntu Server 18.04 LTS? apt install php-mcrypt Чтение списков пакетов ... Готово Создание дерева зависимостей Чтение информации о состоянии ... Готово Пакет php-mcrypt не ...
вопрос задан: 16 May 2018 06:45
33
ответа

Разрешения для файлов по умолчанию для пользователей РНР ВСП-данных

У меня есть PHP установлен на моей машине с Ubuntu. Веб-корень это /var/www и я установить разрешения для этой папки так: судо чаун -Р ftpuser:ВСП-данных в /var/www и ftpuser пользователя я создал, чтобы я мог ...
вопрос задан: 17 January 2011 17:27
32
ответа

Могу ли я запускать Rails и PHP-серверы с одного компьютера?

У меня есть Ubuntu box 10.04, на котором уже установлен LAMP-стек. Я хотел бы поиграть с Rails на этой машине. Есть ли способ установить Rails, не испортив PHP ...
вопрос задан: 16 January 2012 18:00
32
ответа

Получение ошибки от apt-get при попытке установить пакет php5

Я новичок в ubuntu, и я пытаюсь запустить веб-сайт на своем собственном компьютере, но я не могу установить php5. Когда я набрал: sudo apt-get install php5, я получил: пакет php5 недоступен, но упоминается ...
вопрос задан: 18 December 2011 02:06
32
ответа

Установка phpMyAdmin из репозитория, 403 Запрещенная ошибка

Я установил phpMyAdmin из репозиториев, но я получаю запрет 403, когда я обращаюсь к http: //localhost/phpmyadmin/index.php. Apache работает нормально, а также PHP (я использую apache2-mpm-worker с ...
вопрос задан: 23 November 2010 04:54
30
ответов

Не удалось установить php7.1-bcmath на ubuntu 17.10

Я пытаюсь установить битвап пакет Laravel, но этот пакет зависит от bcmath. Всякий раз, когда я пытался установить, это давало мне ошибку. Также я попытался установить его с помощью этой команды: sudo apt-get ...
вопрос задан: 30 January 2018 07:38
30
ответов

Как получить и установить переменные php.ini через терминал

Я хочу изменить некоторые php.ini (php5.6) переменные через терминал. Пример. Мне нужно получить значение post_max_size (на данный момент это 8M), отобразить его в терминале, изменить его на 2048M и отобразить ...
вопрос задан: 27 December 2017 21:56