Проблема Обновления программного обеспечения libplacebo18 на человечности 18.04 [дубликат]

Этот вопрос уже имеет ответ здесь:

Это было начиная с сообщения последнего обновления я не могу установить никакие другие программы из-за этой ошибки, помогите.

Если Вы используете репозитории сторонних производителей, затем отключают их, так как они - общий источник проблем. Теперь выполните следующую команду в терминале: склонный - получают установку-f отказавшая Транзакция: система пакета повреждается, следующие пакеты не встретили зависимости:

mpv: Зависит: libplacebo18 (> = 1.18.0), но это не установлено, Зависит: libxrandr2 (> = 2:1.2.99.3), но 2:1.5.1-1 установлен

Это - сообщение, которое появляется после того, как я запускаю установщик. Чем я пытался работать

sudo apt update

И много других команд для обновления пакета, но это кажется не работе каждый раз.

склонный sudo - поврежденная фиксацией установка, Читая списки пакета... Сделанное дерево зависимостей Здания
Чтение информации состояния... Сделанные зависимости от Исправления... Сделанный следующие пакеты были автоматически установлены и больше не требуются: Использование libdav1d2 libplacebo7 'sudo склонный автоудаляет' для удаления их. Следующие дополнительные пакеты будут установлены: libplacebo18 следующие НОВЫЕ пакеты будет установленным libplacebo18 0 для обновления, 1 для новой установки, 0 для удаления и 29 для не обновления. 1 не полностью установленный или удаленный. Потребность получить 0 КБ B/129 архивов. После этой операции будут использоваться 360 КБ дополнительного дискового пространства. Вы хотите продолжить? [Y/n] y (База данных Reading... В настоящее время установлены 249 564 файла и каталоги.) Подготовка распаковать.../libplacebo18_1.18.0-1~bionic1_amd64.deb... Распаковка libplacebo18:amd64 (1.18.0-1~bionic1)... dpkg: ошибочный архив обработки/var/cache/apt/archives/libplacebo18_1.18.0-1~bionic1_amd64.deb (-распаковывают): попытка перезаписать '/usr/lib/x86_64-linux-gnu/libplacebo.so.18', который находится также в пакете libplacebo7:amd64 1.8.0-1~bionic dpkg-deb: ошибка: подпроцесс вставки был уничтожен сигналом (Поврежденный канал), с Ошибками встретились при обработке:/var/cache/apt/archives/libplacebo18_1.18.0-1~bionic1_amd64.deb E: подпроцесс/usr/bin/dpkg возвратил код ошибки (1)

Это - что-то, что могло помочь, я понятия не имею, что происходит.

3
задан 16 November 2019 в 17:56

1 ответ

Я зафиксировал его силой, перезаписывающей пакет

sudo dpkg -i --force-overwrite /var/cache/apt/archives/libplacebo18_1.18.0-1~bionic1_amd64.deb

, И затем я использовал эту команду для фиксации любых поврежденных пакетов.

sudo apt -f install 
4
ответ дан 1 December 2019 в 15:48

Другие вопросы по тегам:

Похожие вопросы: