Firefox 71.0 не работает над Ubuntu 16.04 LTS

По некоторым причинам Firefox 71.0 не работает над Ubuntu 16.04 LTS.

Я обновил свой Firefox через apt get upgrade к 71,0 версиям и Firefox больше не открывается. Когда я пытаюсь открыть браузер, просто сообщение катастрофического отказа появляется:

enter image description here

Я пытался понизить до 70,0 версий, но другое сообщение появляется, связанный с моими закладками может повредить со снижением.

enter image description here

Я хотел бы знать, существует ли опция или обновить мой Firefox, и это начинает работать, или понижать до 70,0 версий снова, и мои закладки не повреждают.

Заранее спасибо.

РЕДАКТИРОВАНИЕ 1:

Версия Firefox 71.0 появляется, когда я использую apt-cache show firefox | grep Version:

Version: 71.0~b6+build1-0ubuntu0.16.04.1
Version: 70.0+build2-0ubuntu0.16.04.1
Version: 45.0.2+build1-0ubuntu1

Как @guiverc объясненный, согласно здесь, 70 последняя версия. Я не знаю, как я имею 71 версию в наличии.

Когда я использую apt-cache show firefox, следующее сообщение появляется:

Package: firefox
Priority: optional
Section: web
Installed-Size: 191346
Maintainer: Ubuntu Mozilla Team 
Architecture: amd64
Version: 71.0~b6+build1-0ubuntu0.16.04.1
Recommends: xul-ext-ubufox, libcanberra0, libdbusmenu-glib4, libdbusmenu-gtk3-4
Replaces: kubuntu-firefox-installer
Suggests: fonts-lyx
Provides: gnome-www-browser, iceweasel, www-browser
Depends: lsb-release, libatk1.0-0 (>= 1.12.4), libc6 (>= 2.18), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.10.0), libdbus-1-3 (>= 1.9.14), libdbus-glib-1-2 (>= 0.78), libfontconfig1 (>= 2.11.94), libfreetype6 (>= 2.3.5), libgcc1 (>= 1:4.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.31.8), libgtk-3-0 (>= 3.4), libpango-1.0-0 (>= 1.22.0), libpangocairo-1.0-0 (>= 1.14.0), libpangoft2-1.0-0 (>= 1.14.0), libstartup-notification0 (>= 0.8), libstdc++6 (>= 4.6), libx11-6, libx11-xcb1, libxcb-shm0, libxcb1, libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxi6, libxrender1, libxt6
Filename: pool/main/f/firefox/firefox_71.0~b6+build1-0ubuntu0.16.04.1_amd64.deb
Size: 49533706
MD5sum: 16688026d1c819e5ddaba10c510a36f5
SHA1: a251347a565472afa8b3220566be322a39feae9e
SHA256: 7a6445463e427e1f414c7494af75920a405caf790c210da4ecc62e29c16db5db
Description-en: Safe and easy web browser from Mozilla
 Firefox delivers safe, easy web browsing. A familiar user interface,
 enhanced security features including protection from online identity theft,
 and integrated search let you get the most out of the web.
Description-md5: 46b619f510631c4693dc09c1a3778a55
Xul-Appid: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}

РЕДАКТИРОВАНИЕ 2:

@organic-marble спрошенный меня для использования apt policy firefox показать источник программного обеспечения дает мне 71 версию. Результат следующие:

firefox:
  Installed: 71.0~b6+build1-0ubuntu0.16.04.1
  Candidate: 71.0~b6+build1-0ubuntu0.16.04.1
  Version table:
 *** 71.0~b6+build1-0ubuntu0.16.04.1 500
        500 http://ppa.launchpad.net/mozillateam/firefox-next/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
     70.0+build2-0ubuntu0.16.04.1 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     45.0.2+build1-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages

РЕДАКТИРОВАНИЕ 3:

Согласно здесь и здесь, я полагаю, что версия Firefox 71 является бета-версией. Я не знаю, почему моя Ubuntu обновляет до бета-версии.

Кто-то знал бы, как я мог сделать для остановки моей Ubuntu установки бета-версий?

4
задан 7 November 2019 в 03:19

2 ответа

Чтобы вынудить более старый Firefox использовать Ваш профиль, вызовите его с:

$ firefox --allow-downgrade

Вы могли бы также хотеть -P там, для выбора, какой профиль используется.

(Источник: Поддержка Mozilla )

у меня был тот же опыт как Вы с Бетой Firefox PPA: после обновления до 71.0b8, это отказывается работать. Я затем загрузил Бету Firefox непосредственно с Mozilla. Это было также 71.0b8, но это все еще утверждало, что мой профиль был от более новой версии и потребовал --allow-downgrade использовать ее.

1
ответ дан 17 November 2019 в 04:03

Похож Вы добавили PPA, это предназначено для команда, это работает для интеграции Firefox, Thunderbird и т.д. в Ubuntu

71.0~b6+build1-0ubuntu0.16.04.1 500
    500 http://ppa.launchpad.net/mozillateam/firefox-next/ubuntu xenial/main amd64 Packages

, Которую PPA, кажется, содержит предварительный, "работают в прогрессе" версии. Вы могли бы хотеть удалить PPA из своего списка.

Команда для удаления этого PPA:

sudo add-apt-repository --remove ppa:mozillateam/firefox-next
6
ответ дан 17 November 2019 в 04:03

Другие вопросы по тегам:

Похожие вопросы: