Не удалось установить Последнее универсальное ядро для 18,04

Когда я пытаюсь обновить Последнее универсальное ядро для 18,04, потому что у меня были проблемы с замораживанием Ubuntu, в то время как я делаю свои технические разработки, когда партия вкладок открывается и т.д. Таким образом, я нашел решение в запросе stackoverflow обновить универсальное ядро, таким образом, я сделал это sudo apt install — install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04 упомянутый здесь

Я получил следующую ошибку, как решить это

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package —
E: Unable to locate package install-recommends

0
задан 20 February 2020 в 09:58

2 ответа

У Вас есть дополнительные пространства в Вашей команде, поскольку я считал ее и таким образом сказал, что она для установки "установки - рекомендует", для которого нет никакого пакета, таким образом ошибка корректна.

Когда сторонние блоги совершают ошибки, необходимо исправить для этого сами или придерживаться официальных блогов Ubuntu, которые тестировались/рассматривались кем-то еще в команде.

'-' GNU способ записать опцию, и 'установка-recommends' является опцией и подключенный с '-', т.е. пространство между ними не должно быть там.

- установка - рекомендует, установит пакеты для Xorg (https://packages.ubuntu.com/bionic/linux-generic-hwe-18.04, https://packages.ubuntu.com/bionic-updates/xserver-xorg-hwe-18.04)

Я не обеспечил команду по выбору; поскольку команда относится к HWE (аппаратное ядро реализации возможностей) и не GA (общедоступность) ядро, о котором я склонен думать как универсальный (или что первоначально поставлется). Вы также отметите, что официальная документация имеет различные команды для рабочего стола и сервера, операция в секунду, которую игнорирует неофициальное сообщение (таким образом это было бы плохо для Серверов Ubuntu 18.04),

Официальная документация является https://wiki.ubuntu.com/Kernel/LTSEnablementStack

2
ответ дан 20 February 2020 в 22:49

Корректная команда

sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04
0
ответ дан 20 February 2020 в 22:49

Другие вопросы по тегам:

Похожие вопросы: