Неопределенные зависимости для пакетов, необходимых для компиляции FFmpeg [duplicate ]

I tried following the instructions from "How to compile FFmpeg for Ubuntu" at Compile FFmpeg for Ubuntu, Debian, or Mint.

These are:

sudo apt-get update -qq && sudo apt-get -y install \
  autoconf \
  automake \
  build-essential \
  cmake \
  git-core \
  libass-dev \
  libfreetype6-dev \
  libgnutls28-dev \
  libsdl2-dev \
  libtool \
  libva-dev \
  libvdpau-dev \
  libvorbis-dev \
  libxcb1-dev \
  libxcb-shm0-dev \
  libxcb-xfixes0-dev \
  pkg-config \
  texinfo \
  wget \
  yasm \
  zlib1g-dev

However, I get:

The following packages have unmet dependencies.
 libsdl2-dev : Depends: libsdl2-2.0-0 (= 2.0.8+dfsg1-1ubuntu1.18.04.4) but 2.0.9+dfsg1-1ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.
2
задан 20 July 2020 в 13:16

1 ответ

Solved by:

sudo apt-get install libsdl2-2.0-0/bionic

...and let it remove the 32-bit version of libsdl2.

1
ответ дан 30 July 2020 в 22:05

Другие вопросы по тегам:

Похожие вопросы: