Как версии пакета способного и разработчика соответствуют?

Столкнулся с этим при расследовании катастроф плагина DockBarX. apt дает мне следующее:

$ apt show xfce4-whiskermenu-plugin
Package: xfce4-whiskermenu-plugin
Version: 2.1.5-0ubuntu1
Priority: optional
Section: universe/xfce
Origin: Ubuntu
Maintainer: Xubuntu Developers 
Original-Maintainer: Debian Xfce Maintainers 

Однако сайт разработчика даже не перечисляет версию 2.1.5. Самая старая версия, упомянутая в истории версий, 2.3.0 (2018/09/30); 2.1.5 был, вероятно, 5 + несколько лет назад.

Так, версия 2.1.5 в репозитории Ubuntu, гарантировал, что был 2.1.5 разработчиками, имел давно? Или является Ubuntu repo использованием ее собственной, несвязанной нумерации?

0
задан 27 February 2020 в 17:40

1 ответ

Назад в 2018 версия 2.1.5 (в то время) была вручную загружена. Возможно, что веб-сайт разработчика изменился с тех пор.

То, почему это было версией, ударенной к 2.1.5 независимо от синхронизации Debian, неизвестно мне, но эта 'версия' находится специфически только у 18.04 Бионических Бобров - позже, версии Ubuntu имеют более новые варианты, как перечислено на его странице Launchpad.

После того как версия Ubuntu выпускает, редко видеть, что пакеты имеют удары основной версии после факта. Из-за этого, 18.04 (который был выпущен в 2018) имеет старую версию пакета. Вы, вероятно, захотите обновить до более нового выпуска (20.04, после того как он выпущен в паре месяцев) получить 'более новые' версии программного обеспечения.

В этом случае это - разработчики Debian, которые упаковывают его в Debian, и это синхронизирует вниз к Ubuntu во время dev циклов.

0
ответ дан 17 March 2020 в 00:13

Другие вопросы по тегам:

Похожие вопросы: