Slack не может запуститься - Плохое значение RIP

Slack не запускался внезапно. Slack был установлен с помощью Snap.

dmesg :

[63983.140086] ThreadPoolForeg[58617]: segfault at 34d0 ip 00000000000034d0 sp 00007fdb3e23ce08 error 14
[63983.140096] Code: Bad RIP value.
[63983.375855] traps: Chrome_IOThread[58504] trap int3 ip:55c2908ba1c4 sp:7f0ec54347e0 error:0 in slack[55c28e42e000+5caf000]
задан 13 July 2020 в 19:46

3 ответа

Followed guidance in this article on the snapcraft forum, and reverted snap.

sudo snap revert slack

Reverted slack to

slack reverted to 4.4.3

Slack was able to start after being reverted.

ответ дан 30 July 2020 в 22:10

This workaround works for me using latest Slack 4.7.0 (which was causing the issue at first place):

Open terminal and run snap shell:

snap run --shell slack

then execute slack binary:



So the SEGFAULT is caused by --no-sandbox flag in command argument list.

ответ дан 30 July 2020 в 22:10

I also had issues with Slack launching after an upgrade, with what looks like the same error

Jul 11 16:45:43 samloyd kernel: [171452.625726] traps: Chrome_IOThread[114914] trap int3 ip:56465285b1c4 sp:7f543c1797e0 error:0 in slack[5646503cf000+5caf000]

Reverting to 4.4.3 fixed it.

ответ дан 30 July 2020 в 22:10

Другие вопросы по тегам:

Похожие вопросы: