10
ответов

Должен ли я использовать PyQt или PySide для нового проекта Qt?

Недавно я участвовал в разговорах о создании шаблона Quickly для Qt и QtQuick Ubuntu. Идея состоит в том, чтобы сделать так же легко разрабатывать Qt-приложения от концепции до пакета, поскольку это правильно ...
вопрос задан: 22 May 2012 20:47
8
ответов

Установка PyQt4 для Python3

Я пытаюсь запустить мой код с помощью Python3 и PyQt4. Когда я это делаю: gruszczy @ gruszczy-laptop: ~ / Programy / fathom / tools $ python3.1 fathomqt.py Traceback (последний последний вызов): Файл «...
вопрос задан: 19 April 2011 10:25
7
ответов

Приложения PyQt вызывают сбой Window Manager - в чем проблема?

Я обновился до Ubuntu 11.10, и у меня странная проблема. Приложения PyQt, такие как ReText и представленные ниже, заставляют оконный менеджер сходить с ума. Сбой Metacity, зависание Compiz, отображение GNOME Shell / Mutter ...
вопрос задан: 9 July 2012 18:33
6
ответов

QtWebKit на ubuntu 17.04

Я пытаюсь скомпилировать это приложение python из источника. В проекте есть qtwebkit как зависимость, и это, кажется, вызывает проблемы. Как установить qtwebkit на Ubuntu 17.04 64-бит в ...
вопрос задан: 1 February 2018 03:43
4
ответа

Как установить PyQt для Python 3 в Ubuntu 14.10?

Я нашел несколько руководств в Интернете для более ранних версий Ubuntu, но они, похоже, не работают на Ubuntu 14.10; Либо это, либо я делал это неправильно. Я хочу использовать Qt Designer для разработки графического интерфейса, использовать ...
вопрос задан: 28 May 2016 23:20
4
ответа

Я могу разработать человечность для приложений для телефонов в Python? [дубликат]

Кто-либо знает, можем ли мы разработать приложения для человечности для телефонов в Python? PyQT / PySide, казалось бы, поддерживал бы также QML. Но мы можем использовать их по телефонам?
вопрос задан: 14 February 2013 19:36
4
ответа

Как я могу зафиксировать некоторые поврежденные пакеты пакеты PyQt?

Я пытаюсь установить PyQt, но я встретил некоторые трудности (т.е. пакеты, которые не будут обновлены и материал как этот). Я не являюсь очень опытным с Ubuntu, таким образом, некоторая помощь необходима. Вот вывод, который я получаю...
вопрос задан: 11 January 2012 15:42
3
ответа

Как установить PyQt5

Я устанавливаю ROS из источника и получаю сообщение об ошибке PyQt5. [88%] Запуск SIP-генератора для qt_gui_cpp_sip Связывание с Python ... sip: Предупреждение об отказе: qt_gui_cpp.sip: 1:% Номер версии модуля ...
вопрос задан: 26 February 2018 10:08
3
ответа

Не удалось запустить TortoiseHg, сломанные библиотеки и отсутствующие зависимости

Мне тяжело работать TortoiseHg (GUI для меркуриального). PPA серьезно устарел, и нет автономного образа AppImage или SnapCraft. Я ранее задавал этот вопрос в ...
вопрос задан: 18 January 2018 04:40
3
ответа

PyQT Creator Разработчик Qt: нет такого файла или каталога

Существует команда bash, которая поставляется с установкой PyQT Creator под названием designer, которая запускает инструмент под названием Qt Designer, найденный в пакете Qt Creator. Это помогает вам создавать графические интерфейсы - довольно круто ...
вопрос задан: 11 November 2017 03:19
3
ответа

Где ссылка к в настоящее время используемой сохраненной знаковой теме?

Существует несколько связанных вопросов, но я не нашел ни один, что действительно ответило на эту деталь: Где ссылка к текущей сохраненной знаковой теме? Так как знаковая тема может быть изменена, следовательно так также...
вопрос задан: 13 April 2017 05:23
3
ответа

Как установить PyQt для Python 3 в Ubuntu 14.10?

Я нашел несколько обучающих программ в Интернете для более ранних версий Ubuntu, но они, похоже, не работали над Ubuntu 14.10; либо это, либо я делал это неправильно. Я хочу использовать Qt Designer для разработки графического интерфейса, использования
вопрос задан: 28 May 2016 23:20
2
ответа

собственный FAF на человечности (QtWebKit на человечности 17.04 +)

Я пытаюсь выполнить FAF (исходно) в сочетании с FA (через вино) (из-за представлений, которые это сообщение получает и к тому, сколько обновили методы, я решил обновить этот вопрос для него к...
вопрос задан: 14 April 2019 12:09
2
ответа

Как установить Средство просмотра LDOCE5 на Ubuntu

Я использовал Средство просмотра LDOCE5 в течение нескольких лет теперь. Это - большое программное обеспечение (т.е. средство просмотра) для использования Словаря Longman Современного английского языка. На Ubuntu 14.04 и 16.04 я мог установить это програм
вопрос задан: 20 August 2018 12:39
2
ответа

Закрытие не работает в приложении pyqt

Чтобы запустить код: apt-get install python3-venv python3 -m venv venv. venv / bin / activate pip install pyqt5 python3 script.py Код для вставки в script.py: импорт sys из PyQt5.QtCore import QUrl из ...
вопрос задан: 13 August 2018 13:45
2
ответа

Начните использовать PyQt с Qt Creator

Я хотел бы использовать PyQt с некоторым Qt Creator. Сколько и какие пакеты мне нужно установить? $ sudo apt-get install qtcreator Если я устанавливаю только qtcreator, нужно ли устанавливать также PyQt? $ sudo ...
вопрос задан: 12 June 2018 10:16
2
ответа

Проблема с рендерингом шрифтов в определенных приложениях [dубликат]

Установленный Ubuntu 14.04 LTS с Xfce 4.12 на моем Thinkpad T440P несколько недель назад. Это был мой первый реальный контакт с системами Linux. Моя проблема в том, что шрифт, используемый в графическом интерфейсе некоторых из ...
вопрос задан: 5 April 2018 21:50
2
ответа

Как установить PyQt5

Я устанавливаю ROS из источника и получаю ошибку о PyQt5. [88%] Рабочий генератор SIP для qt_gui_cpp_sip привязки Python... потягивают: Депрекация, предупреждающая: qt_gui_cpp.sip:1: номер версии %Module...
вопрос задан: 25 February 2018 23:08
2
ответа

Где хранится ссылка на текущую использованную иконку?

Есть несколько связанных вопросов, но я не нашел ни одного, который действительно ответил бы на эту деталь: где хранится ссылка на текущую тему значка? Поскольку тема значка может быть изменена, значит, тоже ...
вопрос задан: 13 April 2017 15:23
2
ответа

Как установить и запустить qt-designer для python

Я новичок в Ubuntu, я ввел следующие команды: sudo apt-get install python-pyqt и sudo apt-get install qt-designer. Обе команды выполнены успешно, но я не могу понять, как ...
вопрос задан: 27 April 2016 20:36
2
ответа

Проблема во время установки - Ubuntu 12.04

Я устанавливаю Ubuntu 12.04, но у меня была эта ошибка: ошибка произошла при установке пакетов: "Команда' ['debconf-apt-progress' ', -', 'склонный - добираются', '-y', 'установка', 'user-first-login-u1', 'poppler-данные'.....
вопрос задан: 27 June 2014 08:41
2
ответа

Как интегрироваться Python 2.7.4 в Qt 5.0

Мне установили Python 2.7.4, установленный Qt 5.0, PyQt 4.10.4.tar.gz и глоток 4.15.5.tar.gz. Как я могу интегрировать Python со своим QT?
вопрос задан: 1 May 2014 05:38
2
ответа

Python.h: нет такого файла или каталога #include < Python.h >

Когда я пытаюсь скомпилировать pyqt, у меня возникает ошибка, я установил все необходимые компоненты, но проблема не исчезла, найдите ответ на этот вопрос.
вопрос задан: 18 October 2013 21:36
2
ответа

Как получить перевод на Launchpad для пользовательской программы

Я написал программу и загрузил ее в ppa. Эта программа использует переводы, которые я создаю вручную, используя pylupdate4 Translate.pro, затем Qt-Linguist, затем lrelease Translate.pro на моем домашнем ПК. Итак ...
вопрос задан: 26 September 2013 18:17
2
ответа

Компиляция программы Pyqt4

Я пытаюсь упаковать написанную мной программу (используя Pyqt4) в один исполняемый файл для Linux. Я пытался использовать Pyinstaller, однако у него есть проблемы с импортом Gio (для настроек) из gi.repository ...
вопрос задан: 28 February 2012 06:49
2
ответа

Как настроить PyQt4 для Eclipse Python 3 в Ubuntu?

Я установил PyQt4 с синаптическим. Я использую Python3, поэтому мне нужно настроить путь для PyQt4 в eclipse, но, похоже, синаптический только установил PyQt4 для python 2, так как я нашел только относительные файлы и ...
вопрос задан: 30 October 2011 08:05
2
ответа

Как настроить PyQt4 для затмения Python 3 в Ubuntu?

Я установил PyQt4 с синаптической. Я использую Python3, поэтому мне нужно настроить путь для PyQt4 в Eclipse, но кажется, что Synaptic только установил PyQt4 для Python 2, поскольку я нашел только относительные файлы и
вопрос задан: 30 October 2011 06:05
2
ответа

Быстро шаблон для PyQt?

Поскольку мне нравятся Qt и Python, существует ли шаблон Quickly для PyQt, аналогичный шаблону PyGTK?
вопрос задан: 10 October 2011 21:09
1
ответ

Как дать конкретной программе чтения / записи pyqt разрешение?

Я использую программу под названием gnuradio-companion. Если я запускаю его без привилегий root, я ничего не могу сохранить, потому что у меня нет привилегий чтения / записи. Это дает: /usr/lib/python2.7/dist-packages / ...
вопрос задан: 29 May 2019 22:20
1
ответ

Ubuntu 18.10 не запускается с драйверов Nvidia

Я обновил до Ubuntu 18.10 из Ubuntu 18.04. У меня есть две проблемы, но я думаю, что они связаны. У меня есть видеокарта NVIDIA. Проблема 1: если у меня есть исходные драйверы графической платы NVIDIA, то мой...
вопрос задан: 31 October 2018 11:20