18
ответов

Redmine не может работать на apache2 с пассажиром: несовместимая версия библиотеки nokogiri

Я хочу установить redmine на свой компьютер. Я работал с учебниками из http://redmine.org/, чтобы развернуть redmine на моем ПК. После установки ruby, дополнительных пакетов и redmine, я хочу настроить apache2 для ...
вопрос задан: 4 July 2017 11:10
9
ответов

Можно ли добавить RubyMine в панель на Ubuntu 17.10?

Я загрузил архив RubyMine и извлек его в свой домашний каталог. Когда я выполняю ./RubyMine/bin/rubymine.sh, запускается среда IDE, а на панели Ubuntu я вижу значок RubyMine. Когда я нажимаю правой кнопкой мыши ...
вопрос задан: 18 February 2018 11:58
2
ответа

Я получил сообщение этого сообщения в rails “ Зависимость tzinfo-data ”

Я просто устанавливаю ruby ​​на rails пару дней назад и каждый раз, когда создаю новый проект в консоли, я получил это сообщение: зависимость tzinfo-data (& gt; = 0) не будет использоваться ни одной из платформ ...
вопрос задан: 26 January 2017 19:41
2
ответа

не удалось установить RVM при попытке установить RoR

Я пытаюсь установить RoR в свою систему. Я следую учебнику по цифровому океану. Пока я пытаюсь установить RVM \ curl -L https://get.rvm.io | bash -s стабильно с этой командой, я получаю следующую ошибку: ...
вопрос задан: 26 July 2015 07:47
1
ответ

Сбой Ruby on Rails в Ubuntu 19.0.4

Как добавить следующие зависимости для запуска моего сервера rails: При запуске сервера с помощью следующей команды bin / start thin появляется следующее сообщение об ошибке: /usr/share/rvm/rubies/ruby-2.3.1/lib / ...
вопрос задан: 11 May 2019 06:05
1
ответ

Обработка JSON-данных в Select2

У меня проблема с расшифровкой, как обрабатывать мои json-данные для Select2, часть этого может также заключаться в том, что мой кофе-код не является отличным. В моем контроллере у меня есть следующее: json = & gt; User.select (...
вопрос задан: 13 August 2018 12:32
1
ответ

Создайте новую запись из link_to результатов в urlgenerationerror

Я пытаюсь создать запись в таблице, когда пользователь нажимает на ссылку. Однако при попытке загрузить представление генерируется следующая ошибка. ActionController :: UrlGenerationError в ...
вопрос задан: 13 August 2018 11:25
1
ответ

Вызов приглашения mysql в ubuntu

Я не могу получить доступ к приглашению mysql, как после ввода этого корня mysql-u в командной строке в соответствии с книгой Agile Web Development с Rails, 4th Edition. Вместо этого я получаю список ...
вопрос задан: 17 November 2015 07:05
0
ответов

Невозможно подключить MySQL к Ruby on Rails в Ubuntu 19.04

Я сталкиваюсь с трудностями при установке Ruby Gems на мою Ubuntu 19.04. Каждый раз, когда я пытаюсь установить gem, у меня возникает ошибка make, выход из кода 2. Однако MySQL правильно установлен в моей ОС. И даже Руби ...
вопрос задан: 11 June 2019 05:32
0
ответов

Какой DocumentRoot использовать?

У меня есть приложение rails, установленное в каталоге с именем "testapp". Но когда я запускаю конфигурационный тест apache2ctl, он говорит мне, что корень документа неверен. Есть ли в любом случае, я могу проверить, что документ должен корень ...
вопрос задан: 9 May 2019 16:42
0
ответов

BrowserifyRails :: BrowserifyError в индексе Pages #

Я новичок в Ruby on Rails. Я загружаю код из local в aws с nginx (passanger). Каждый раз, когда я сталкиваюсь с этой ошибкой (показано на картинке, введите здесь описание изображения). Ошибка при запуске `/ var / www / ...
вопрос задан: 13 August 2018 12:58
0
ответов

Rails devise reset password failed, если запись пользователя содержит недопустимые данные

У меня есть существующее приложение в производстве, где мы добавили новые обязательные поля в запись пользователя. В результате функция забытых паролей терпит неудачу. Я считаю, что сбой происходит в ...
вопрос задан: 13 August 2018 11:34
0
ответов

Дифференциация между модулем gem и моделью AR

Я использую камень Etsy, который является листинговым модулем. У меня также есть соответствующая модель листинга в моем приложении. Я пытаюсь настроить стороннего рабочего для работы с драгоценным камнем, вызвать некоторые методы и обновить ...
вопрос задан: 13 August 2018 11:32
0
ответов

Использование Omniauth для взаимодействия с Office365 / Sharepoint REST api

Приложение Rails должно взаимодействовать с Sharepoint для извлечения и хранения документов. Для этого я хочу использовать Apache Office365 / Sharepoint REST. И, конечно же, эти запросы должны быть ...
вопрос задан: 13 August 2018 11:00
0
ответов

Откуда я изучаю новые концепции рубина [в ожидании]

Я новичок в ROR. Я хочу научиться FOR basic, чтобы продвинуться на уровень, поэтому мне нужны некоторые сайты с животными, в которых я буду идти вперед и легко научиться ROR. Пожалуйста, помогите мне, если вы знаете некоторые бесплатные сайты. Заранее
вопрос задан: 13 August 2018 10:49
0
ответов

Как оптимизировать загрузку данных с помощью Rails Api?

Для отображения информации необходимо установить определенный предел. То есть, если в базе данных хранится несколько сотен тысяч и даже миллионов записей, то при использовании разбивки на страницы или ...
вопрос задан: 13 August 2018 10:44
0
ответов

Невозможно проверить подлинность CSRF-маркера при использовании пользовательского URL-адреса субдомена в localhost

Я использую devem gem для аутентификации. Раньше он работал нормально, когда я запускал рельсы в локальном хосте: 3000. но когда я отредактировал мой / etc / hosts и добавил 127.0.0.1 tenant1.lv.me в файл моих хостов, я ...
вопрос задан: 13 August 2018 10:32
0
ответов

«Инструмент уязвимости Jackhammer» Ошибка входа, хотя я использую правильные учетные данные!

Я пытаюсь установить инструмент уязвимости Jackhammer на моем Ubuntu 16.04.3 LTS. Более подробную информацию об этом инструменте можно найти здесь https://github.com/olacabs/jackhammer, а руководство пользователя https: // jch ....
вопрос задан: 3 November 2017 11:56
0
ответов

Как создать структуру каталога базы данных для MySQL?

Я следовал этому руководству: https://www.digitalocean.com/community/tutorials/how-to-use-mysql-with-your-ruby-on-rails-application-on-ubuntu-14-04 До сих пор, Я установил mysql-сервер mysql-client ...
вопрос задан: 4 September 2017 22:34
0
ответов

Запуск Rails WEBrick падает

Я использую сервер «rails» для запуска Rails. Я получаю следующее: => Загрузка WEBrick => Приложение Rails 5.1.3, начиная с разработки по адресу http: // localhost: 3000 => Запустить сервер rails -h для ...
вопрос задан: 2 September 2017 12:04
0
ответов

16.04.2 LTS. Создайте ISO всей установки, которая может быть установлена ​​в другом месте

У меня есть сервер ubuntu, выступающий в роли веб-сервера. Он запускает приложение Ruby on Rails с помощью Passenger + Apache. Я хотел бы создать ISO установки, включая все необходимое для создания ...
вопрос задан: 4 July 2017 11:03
0
ответов

не удалось установить жонглирование json в ubuntu

Я установил рубин на рельсах, используя rvm. Я пытаюсь связать установку более старого проекта, который у меня был на предыдущем компьютере, но при запуске команды установки пакета:
вопрос задан: 18 March 2017 08:14
0
ответов

Сервер Apache2 недоступен из-за пределов локального хоста

Поэтому я пошел за некоторыми руководствами, и мне удалось установить сервер, но по какой-то причине его можно получить только через localhost на моем ноутбуке (окна и виртуальную машину ubuntu), когда я пытаюсь получить доступ ...
вопрос задан: 25 February 2017 21:21
0
ответов

Почему я не могу создать Ruby-код из Sublime Text 3, когда я запускаю его из Ubuntu Dash vs Ubuntu Terminal

ruby -v: ruby ​​2.2.2p95 (2015-04-13 revision 50295) [x86_64-linux], который ruby: /home/iuser/.rbenv/shims/ruby rails -v: Rails 4.2.3 subl -v: Sublime Text Build 3126 Ubuntu: Ubuntu 16.04.1 LTS Это не ...
вопрос задан: 22 December 2016 03:49
0
ответов

Ошибка при создании базы данных mysql в процессе производства

Я пытаюсь запустить команду rake db: setup RAILS_ENV = "production" Но это приводит к следующей ошибке: DEPRECATION WARNING: Передача строки в ActiveRecord :: Base.establish_connection для ...
вопрос задан: 17 November 2015 07:56
0
ответов

Gem Debugger не будет устанавливать с установкой пакета

Я установил рубин на рельсах, используя rvm. Я использую 2.2.0 ruby ​​и 4.2.0 Rails. Я попытался запустить установку пакета в более раннем проекте, который я разработал на прежнем компьютере, но я получаю: Gem :: Ext :: BuildError: ...
вопрос задан: 3 October 2015 12:18
0
ответов

Отсутствует ошибка расширения PHP imap

Я следую этой ссылке для установки Kaltura. Но я получаю проблему на этапе sudo php install.php. sneha @ SCS-I82: ~ / Downloads / kalturaCE_v3.0.0-instructure $ sudo php install.php Спасибо за ...
вопрос задан: 3 September 2015 09:11
0
ответов

Почему моя система не может найти libreadline, когда я уверен, что я ее установил?

Я пытаюсь настроить chromebook для разработки с помощью crouton и ubuntu. Я использую рецепт railsgirls для установки рельсов, и я застреваю в: E: Не удалось найти пакет libreadline I ...
вопрос задан: 5 August 2015 14:38